diff mbox series

[bug#52568] gnu: ableton-link: Run tests conditionally.

Message ID e3f1183f0405a24d3194ce0a886fd15f08eacefc.1639729803.git.avityazev@posteo.org
State Accepted
Headers show
Series [bug#52568] gnu: ableton-link: Run tests conditionally. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Aleksandr Vityazev Dec. 17, 2021, 8:30 a.m. UTC
* gnu/packages/audio.scm (ableton-link)[arguments]: Respect TESTS? option.
---
 gnu/packages/audio.scm | 11 ++++++-----
 1 file changed, 6 insertions(+), 5 deletions(-)

Comments

Nicolas Goaziou Dec. 17, 2021, 8:35 a.m. UTC | #1
Hello,

Aleksandr Vityazev <avityazev@posteo.org> writes:

> * gnu/packages/audio.scm (ableton-link)[arguments]: Respect TESTS?
> option.

Applied. Thank you.

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index f5fda6d4e9..beae167fb3 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -5245,11 +5245,12 @@  (define-public ableton-link
        #:phases
        (modify-phases %standard-phases
          (replace 'check
-           (lambda* (#:key inputs #:allow-other-keys)
-             (let* ((python (search-input-file inputs "/bin/python3"))
-                    (run-tests "../source/ci/run-tests.py"))
-               (invoke python run-tests "--target" "LinkCoreTest")
-               (invoke python run-tests "--target" "LinkDiscoveryTest"))))
+           (lambda* (#:key inputs tests? #:allow-other-keys)
+             (when tests?
+               (let* ((python (search-input-file inputs "/bin/python3"))
+                      (run-tests "../source/ci/run-tests.py"))
+                 (invoke python run-tests "--target" "LinkCoreTest")
+                 (invoke python run-tests "--target" "LinkDiscoveryTest")))))
          (add-before 'install 'patch-cmake
            (lambda* (#:key inputs #:allow-other-keys)
              (let* ((source "../source/"))