diff mbox series

[bug#73073,v2,4/8] gnu: smithforth: Move system.fs origin from phases to native-inputs.

Message ID e3d9fdc9bf1d097376a275064ae90559f2cda599.1725930587.git.zimon.toutoune@gmail.com
State New
Headers show
Series Allow origin inside inputs with "new style". | expand

Commit Message

Simon Tournier Sept. 10, 2024, 1:27 a.m. UTC
* gnu/packages/dlang.scm (smithforth)[arguments]<phases>: Move system.fs
origin from here...
[native-inputs]: ...to here.

Change-Id: I82ff81f72dbe2ecf70fbbd44674596e1a62cadcf
---
 gnu/packages/forth.scm | 20 +++++++++++---------
 1 file changed, 11 insertions(+), 9 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/forth.scm b/gnu/packages/forth.scm
index 6e8d8cdc4c..c523887871 100644
--- a/gnu/packages/forth.scm
+++ b/gnu/packages/forth.scm
@@ -75,7 +75,15 @@  (define-public smithforth
         (sha256
           (base32 "0a39pv7529llsa3f48fmvwvlcp3f9v8qkn5ziw2l6kxf0qvli3lm"))))
     (build-system trivial-build-system)
-    (native-inputs (list xxd))
+    (native-inputs (list xxd
+                         (origin
+                           (method url-fetch)
+                           (uri (string-append
+                                 "https://dacvs.neocities.org/SF/system"
+                                 version "fs.txt"))
+                           (sha256
+                            (base32
+                             "17v1pp64s6n8q8w3kg48nd7zdcx2208y4svr5fpfms5lkyzg7z1m")))))
     (arguments
       (list
         #:modules '((guix build utils))
@@ -84,14 +92,8 @@  (define-public smithforth
             (use-modules (guix build utils)
                          (ice-9 textual-ports))
             (let* ((sforth.dmp #$(package-source this-package))
-                   (system.fs  #$(origin
-                                   (method url-fetch)
-                                   (uri (string-append
-                                          "https://dacvs.neocities.org/SF/system"
-                                          version "fs.txt"))
-                                   (sha256
-                                    (base32
-                                     "17v1pp64s6n8q8w3kg48nd7zdcx2208y4svr5fpfms5lkyzg7z1m"))))
+                   (system.fs  #$(this-package-native-input
+                                  (string-append "system" version "fs.txt")))
                    (xxd        (string-append (assoc-ref %build-inputs "xxd")
                                               "/bin/xxd"))
                    (bin        (string-append (assoc-ref %outputs "out") "/bin")))