[bug#77159,7/7] gnu: zathura-cb: Update to 0.1.11.

Message ID e37781c7149cac742e67d71c51c41a556568347e.1742591224.git.wongandj@icloud.com
State New
Headers
Series Update Zathura and plugins |

Commit Message

Andrew Wong March 21, 2025, 9:11 p.m. UTC
  * gnu/packages/pdf.scm (zathura-cb): Update to 0.1.11.
[arguments] <#:phases>: Remove unneeded 'patch-plugin-directory phase

Change-Id: I549314a02fb4a639577c6e2125a5fddafbb1853e
---
 gnu/packages/pdf.scm | 31 ++++++++++---------------------
 1 file changed, 10 insertions(+), 21 deletions(-)
  

Patch

diff --git a/gnu/packages/pdf.scm b/gnu/packages/pdf.scm
index 4a32473f89..1cc5fd0e8e 100644
--- a/gnu/packages/pdf.scm
+++ b/gnu/packages/pdf.scm
@@ -514,31 +514,20 @@  (define-public xpdf
 (define-public zathura-cb
   (package
     (name "zathura-cb")
-    (version "0.1.10")
-    (source (origin
-              (method url-fetch)
-              (uri
-               (string-append "https://pwmt.org/projects/zathura-cb/download/zathura-cb-"
-                              version ".tar.xz"))
-              (sha256
-               (base32
-                "1j5v32f9ki35v1jc7a067anhlgqplzrp4fqvznlixfhcm0bwmc49"))))
+    (version "0.1.11")
+    (source
+     (origin (method url-fetch)
+             (uri (string-append "https://pwmt.org/projects/zathura-cb"
+                                 "/download/zathura-cb-" version ".tar.xz"))
+             (sha256
+              (base32 "0ixx5wbj9x8zrakdrrqdfjcsyhcl73v5cdf4b0raj86w9jjiw82f"))))
     (native-inputs (list pkg-config))
     (inputs (list libarchive zathura))
     (build-system meson-build-system)
     (arguments
-     `(#:tests? #f                      ; package does not contain tests
-       #:phases
-       (modify-phases %standard-phases
-         (add-after 'unpack 'patch-plugin-directory
-           ;; Something of a regression in 0.1.10: the new Meson build system
-           ;; now hard-codes an incorrect plugin directory.  Fix it.
-           (lambda* (#:key outputs #:allow-other-keys)
-             (substitute* "meson.build"
-               (("(install_dir:).*" _ key)
-                (string-append key
-                               "'" (assoc-ref outputs "out") "/lib/zathura'\n")))
-             #t)))))
+     (list #:tests? #f                  ; package does not contain tests
+           #:configure-flags
+           #~(list (string-append "-Dplugindir=" #$output "/lib/zathura"))))
     (home-page "https://pwmt.org/projects/zathura-cb/")
     (synopsis "Comic book support for zathura (libarchive backend)")
     (description "The zathura-cb plugin adds comic book support to zathura