[bug#76269] gnu: vtk: Update to 9.4.1
Commit Message
* gnu/packages/image-processing.scm (vtk): Update to 9.4.1.
Change-Id: Ife39df610c4487683a5c8d72b60eb750530c1358
---
gnu/packages/image-processing.scm | 9 ++++-----
1 file changed, 4 insertions(+), 5 deletions(-)
base-commit: bcce7f8fa8b821b76591b297f61d473c5972e397
Comments
Hi Lars,
Lars Bilke <lars.bilke@ufz.de> skribis:
> * gnu/packages/image-processing.scm (vtk): Update to 9.4.1.
>
> Change-Id: Ife39df610c4487683a5c8d72b60eb750530c1358
Apparently this breaks at least freecad:
--8<---------------cut here---------------start------------->8---
cd /tmp/guix-build-freecad-1.0.0.drv-0/build/src/Mod/CAM && /gnu/store/2lxfijiqqljxdxr2ppqqrn5czkh4r1rq-cmake-minimal-3.24.2/bin/cmake -E copy /tmp/guix-build-freecad-1.0.0.drv-0/source/src/Mod/CAM/Path/Op/Util.py /tmp/guix-build-freecad-1.0.0.drv-0/build/Mod/CAM/Path/Op/Util.py
/tmp/guix-build-freecad-1.0.0.drv-0/source/src/3rdParty/salomesmesh/src/SMDS/SMDS_UnstructuredGrid.cpp: In member function ‘void SMDS_UnstructuredGrid::BuildLinks()’:
/tmp/guix-build-freecad-1.0.0.drv-0/source/src/3rdParty/salomesmesh/src/SMDS/SMDS_UnstructuredGrid.cpp:1030:25: error: no matching function for call to ‘vtkCellLinks::BuildLinks(SMDS_UnstructuredGrid*)’
1030 | GetLinks()->BuildLinks(this);
| ~~~~~~~~~~~~~~~~~~~~~~^~~~~~
In file included from /tmp/guix-build-freecad-1.0.0.drv-0/source/src/3rdParty/salomesmesh/inc/SMDS_UnstructuredGrid.hxx:30,
from /tmp/guix-build-freecad-1.0.0.drv-0/source/src/3rdParty/salomesmesh/src/SMDS/SMDS_UnstructuredGrid.cpp:20:
/gnu/store/gr8mwbl3zlx9hc4x9k5s9sgcy2kp4sr9-vtk-9.4.1/include/vtk-9.4/vtkCellLinks.h:64:8: note: candidate: ‘virtual void vtkCellLinks::BuildLinks()’
64 | void BuildLinks() override;
| ^~~~~~~~~~
/gnu/store/gr8mwbl3zlx9hc4x9k5s9sgcy2kp4sr9-vtk-9.4.1/include/vtk-9.4/vtkCellLinks.h:64:8: note: candidate expects 0 arguments, 1 provided
--8<---------------cut here---------------end--------------->8---
Could you take a look? (Perhaps the solution will be to retain the
previous version of VTK for use in packages like this one.)
More generally, could you test with:
guix build -P1 vtk@9.4.1 -P1 vtk@7
?
Dependent packages like ‘python-fenics-fiat’ are already broken, so it’s
“okay” to keep them broken.
Thanks,
Ludo’.
Dear Ludovic,
thanks for your comments. I have uploaded a patch for freecad, this one:
https://github.com/FreeCAD/FreeCAD/commit/fafff3a08b7a6212ce3417e08b18cb2fc8e7e868
I hope this is fine.
Sincerely,
Lars
On 18 Feb 2025, at 18:19, Ludovic Courtès wrote:
> Hi Lars,
>
> Lars Bilke <lars.bilke@ufz.de> skribis:
>
>> * gnu/packages/image-processing.scm (vtk): Update to 9.4.1.
>>
>> Change-Id: Ife39df610c4487683a5c8d72b60eb750530c1358
>
> Apparently this breaks at least freecad:
>
> --8<---------------cut here---------------start------------->8---
> cd /tmp/guix-build-freecad-1.0.0.drv-0/build/src/Mod/CAM &&
> /gnu/store/2lxfijiqqljxdxr2ppqqrn5czkh4r1rq-cmake-minimal-3.24.2/bin/cmake
> -E copy
> /tmp/guix-build-freecad-1.0.0.drv-0/source/src/Mod/CAM/Path/Op/Util.py
> /tmp/guix-build-freecad-1.0.0.drv-0/build/Mod/CAM/Path/Op/Util.py
> /tmp/guix-build-freecad-1.0.0.drv-0/source/src/3rdParty/salomesmesh/src/SMDS/SMDS_UnstructuredGrid.cpp:
> In member function ‘void SMDS_UnstructuredGrid::BuildLinks()’:
> /tmp/guix-build-freecad-1.0.0.drv-0/source/src/3rdParty/salomesmesh/src/SMDS/SMDS_UnstructuredGrid.cpp:1030:25:
> error: no matching function for call to
> ‘vtkCellLinks::BuildLinks(SMDS_UnstructuredGrid*)’
> 1030 | GetLinks()->BuildLinks(this);
> | ~~~~~~~~~~~~~~~~~~~~~~^~~~~~
> In file included from
> /tmp/guix-build-freecad-1.0.0.drv-0/source/src/3rdParty/salomesmesh/inc/SMDS_UnstructuredGrid.hxx:30,
> from
> /tmp/guix-build-freecad-1.0.0.drv-0/source/src/3rdParty/salomesmesh/src/SMDS/SMDS_UnstructuredGrid.cpp:20:
> /gnu/store/gr8mwbl3zlx9hc4x9k5s9sgcy2kp4sr9-vtk-9.4.1/include/vtk-9.4/vtkCellLinks.h:64:8:
> note: candidate: ‘virtual void vtkCellLinks::BuildLinks()’
> 64 | void BuildLinks() override;
> | ^~~~~~~~~~
> /gnu/store/gr8mwbl3zlx9hc4x9k5s9sgcy2kp4sr9-vtk-9.4.1/include/vtk-9.4/vtkCellLinks.h:64:8:
> note: candidate expects 0 arguments, 1 provided
> --8<---------------cut here---------------end--------------->8---
>
> Could you take a look? (Perhaps the solution will be to retain the
> previous version of VTK for use in packages like this one.)
>
> More generally, could you test with:
>
> guix build -P1 vtk@9.4.1 -P1 vtk@7
>
> ?
>
> Dependent packages like ‘python-fenics-fiat’ are already broken,
> so it’s
> “okay” to keep them broken.
>
> Thanks,
> Ludo’.
@@ -323,7 +323,7 @@ (define-public opencolorio
(define-public vtk
(package
(name "vtk")
- (version "9.3.0")
+ (version "9.4.1")
(source (origin
(method url-fetch)
(uri (string-append "https://vtk.org/files/release/"
@@ -331,7 +331,7 @@ (define-public vtk
"/VTK-" version ".tar.gz"))
(sha256
(base32
- "1s8vd34nhrgnw1bf9zhfn062d53fwq3csjfwvm7lxcr5a8lvkizx"))
+ "0aa5pkw2xxzksl48ldbj3cq6r4y4mxvcpl66f64gkah2s34b0ly2"))
(modules '((guix build utils)))
(snippet
'(begin
@@ -341,7 +341,7 @@ (define-public vtk
(string-append "ThirdParty/" dir "/vtk" dir)))
;; pugixml depended upon unconditionally
'("doubleconversion" "eigen" "expat" "freetype" "gl2ps"
- "glew" "hdf5" "jpeg" "jsoncpp" "libharu" "libproj"
+ "hdf5" "jpeg" "jsoncpp" "libharu" "libproj"
"libxml2" "lz4" "netcdf" "ogg" "png" "sqlite" "theora"
"tiff" "zlib"))
(substitute* "IO/ExportPDF/vtkPDFContextDevice2D.cxx"
@@ -360,7 +360,6 @@ (define-public vtk
"-DVTK_MODULE_USE_EXTERNAL_VTK_expat=ON"
"-DVTK_MODULE_USE_EXTERNAL_VTK_freetype=ON"
"-DVTK_MODULE_USE_EXTERNAL_VTK_gl2ps=ON"
- "-DVTK_MODULE_USE_EXTERNAL_VTK_glew=ON"
"-DVTK_MODULE_USE_EXTERNAL_VTK_hdf5=ON"
"-DVTK_MODULE_USE_EXTERNAL_VTK_jpeg=ON"
"-DVTK_MODULE_USE_EXTERNAL_VTK_jsoncpp=ON"
@@ -380,7 +379,7 @@ (define-public vtk
"-DVTK_WRAP_PYTHON=ON"
"-DVTK_PYTHON_VERSION:STRING=3"
- "-DVTK_SMP_ENABLE_OPENNMP=ON"
+ "-DVTK_SMP_ENABLE_OPENMP=ON"
"-DVTK_SMP_ENABLE_TBB=ON"
"-DVTK_USE_MPI=ON"
#$@(if (target-riscv64?)