diff mbox series

[bug#57756,1/3] gnu: add sbcl-xml-emitter

Message ID e343f3641b319d532c72ece8586c2279e20e8bc4.1663173808.git.trev@trevdev.ca
State Accepted
Headers show
Series [bug#57756,1/3] gnu: add sbcl-xml-emitter | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Trevor Richards Sept. 12, 2022, 9:10 p.m. UTC
---
 gnu/packages/lisp-xyz.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)

Comments

Guillaume Le Vaillant Sept. 15, 2022, 8:40 a.m. UTC | #1
Patches pushed as d10bc44c2452aeb81de36a33257c327e30ffbc1f and following
with a few modifications.
Thanks.
diff mbox series

Patch

diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 4da0323677..01719e05b2 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -35,6 +35,7 @@ 
 ;;; Copyright © 2022 Paul A. Patience <paul@apatience.com>
 ;;; Copyright © 2022 Thomas Albers Raviola <thomas@thomaslabs.org>
 ;;; Copyright © 2022 Arun Isaac <arunisaac@systemreboot.net>
+;;; Copyright © 2022 Trevor Richards <trev@trevdev.ca>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -3799,6 +3800,28 @@  (define-public ecl-markup-reader
 (define-public cl-markup-reader
   (sbcl-package->cl-source-package sbcl-markup-reader))
 
+(define-public sbcl-xml-emitter
+  (package
+    (name "sbcl-xml-emitter")
+    (version "1.1.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/VitoVan/xml-emitter.git")
+                    (commit "1a93a5ab084a10f3b527db3043bd0ba5868404bf")))
+              (sha256
+               (base32
+                "1w9yx8gc4imimvjqkhq8yzpg3kjrp2y37rjix5c1lnz4s7bxvhk9"))))
+    (build-system asdf-build-system/sbcl)
+    (inputs `(("cl-utilities" ,sbcl-cl-utilities)
+              ("1am" ,sbcl-1am)))
+    (synopsis "A common lisp library for emitting XML output")
+    (description "Simply emit XML, with some complexity for handling indentation.
+It can be used to produce all sorts of useful XML output; it has an RSS 2.0
+ emitter built in, so you can make RSS feeds trivially.")
+    (home-page "https://www.cliki.net/xml-emitter")
+    (license license:expat)))
+
 (define-public sbcl-cl-mustache
   (package
     (name "sbcl-cl-mustache")