diff mbox series

[bug#63007,core-updates] gnu: python-aenum: Update to 3.1.12.

Message ID e2bdde498536faaa60e1ff6156fdaa92921e9219.1682113467.git.kaelyn.alexi@protonmail.com
State New
Headers show
Series [bug#63007,core-updates] gnu: python-aenum: Update to 3.1.12. | expand

Commit Message

Kaelyn Takata April 21, 2023, 9:46 p.m. UTC
* gnu/packages/python-xyz.scm (python-aenum): Update to 3.1.12.
[source]: Add snippet to delete Python 2 specific files.
---
 gnu/packages/python-xyz.scm | 9 +++++++--
 1 file changed, 7 insertions(+), 2 deletions(-)


base-commit: 3f7ae420d8a54d4e2ab7f349c40d8930fe9e0771
--
2.39.2

Comments

Kaelyn Takata April 21, 2023, 9:52 p.m. UTC | #1
Hi,

I just realized this could easily apply to master as well; I marked the patch for core-updates because the current version of python-aenum builds fine on master but has test failures on core-updates. I discovered and wanted to fix the failure there as part of testing my local profile--including a package definition for the OnlyKey CLI, which depends on python-aenum and which seems to work fine with the updated version.

Cheers,
Kaelyn
Andreas Enge April 22, 2023, 8:28 p.m. UTC | #2
Hello Kaelyn,

thanks for the patch, which I applied to core-updates. It will soon
arrive in master anyway.

Andreas
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 10b28f0888..2f5123fa51 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -2407,13 +2407,18 @@  (define-public python-textparser
 (define-public python-aenum
   (package
     (name "python-aenum")
-    (version "2.2.4")
+    (version "3.1.12")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "aenum" version))
        (sha256
-        (base32 "0r1812bjm72x73pl7y4yhffr4zbdjgxa08avsy4b3di0pqgqv0l1"))))
+        (base32 "1w1ffkcxgnimi5w8802qk6w2qxz9k8hpvsg6yy2zi08ahs8iqlry"))
+       (modules '((guix build utils)))
+       (snippet
+        ;; Delete the Python 2 specific files which won't compile load
+        ;; in Python 3.
+        '(for-each delete-file (find-files "." "_py2.py$")))))
     (build-system python-build-system)
     (arguments
      `(#:phases (modify-phases %standard-phases