diff mbox series

[bug#66814,gnome-team,v3] gnu: at-spi2-core: Update to 2.48.4.

Message ID e2ac89a72f135611849f47f10f904d0777e66e1b.1698750173.git.vivien@planete-kraus.eu
State New
Headers show
Series [bug#66814,gnome-team,v3] gnu: at-spi2-core: Update to 2.48.4. | expand

Commit Message

Vivien Kraus Oct. 23, 2023, 4:20 p.m. UTC
* gnu/packages/gtk.scm (at-spi2-core): Update to 2.48.4.
(at-spi2-core-with-documentation)[#:phases]: Adjust accordingly.
[native-inputs]: Remove docbook-xml-4.3 and gtk-doc/stable.
Add gi-docgen, python, and python-sphinx.

Change-Id: I3fc09c79f1ae5594fe9ad50e7212fbee11ce8a90
Co-authored-by: Liliana Marie Prikler <liliana.prikler@gmail.com>
---

Thank you!  The build was fine for x86_64, but it did fail on i686 with the
described segfault of dbus-run-session.  Using the other patch series to
update (gnu packages glib), #66689, I could get dbus-run-session to print a
warning about more entries than 128 to listen to for changes before crashing,
which led me to the linked issue.  It does not mean the issue we experience
here is related: maybe there is a problem when listening for changes on more
than 128 directories, and maybe there is another problem when actually reading
them.

In any case, it is worth remembering that when such a crash occurs in
dbus-run-session, it may be because there are too many entries in
XDG_DATA_DIRS.  Now I’ll see if that fixes #66823 (it has about a hundred of
XDG_DATA_DIRS, but less than 128).

The solution is not very satisfying.  Maybe we could create a directory-union
of all the XDG_DATA_DIRS?  I don’t know how to do that in the check phase of a
build.

At least it should now work.

Best regards,

Vivien

 gnu/packages/gtk.scm | 43 +++++++++++++++++++------------------------
 1 file changed, 19 insertions(+), 24 deletions(-)


base-commit: 2677bf985c0025d04ffdcff31763978b633dbc58
diff mbox series

Patch

diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 21a12689b7..08fed555c9 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -106,6 +106,7 @@  (define-module (gnu packages gtk)
   #:use-module (gnu packages python)
   #:use-module (gnu packages python-build)
   #:use-module (gnu packages python-xyz)
+  #:use-module (gnu packages sphinx)
   #:use-module (gnu packages gstreamer)
   #:use-module (gnu packages guile)
   #:use-module (gnu packages guile-xyz)
@@ -792,7 +793,7 @@  (define-public at-spi2-core
   (hidden-package
    (package
      (name "at-spi2-core")
-     (version "2.45.90")
+     (version "2.48.4")
      (source (origin
                (method url-fetch)
                (uri (string-append "mirror://gnome/sources/" name "/"
@@ -800,7 +801,7 @@  (define-public at-spi2-core
                                    name "-" version ".tar.xz"))
                (sha256
                 (base32
-                 "03dba3c6m3sfapkkbbgzvbi1qcmrrlppydxjjs1m8ds9qb9hl1g9"))))
+                 "05d5azffbglnvqzwk8ngg61jksm3brrwhmfpymsrccz8j8lv3v19"))))
      (build-system meson-build-system)
      (arguments
       (list
@@ -816,10 +817,15 @@  (define-public at-spi2-core
                      (lambda _
                        ;; xfconfd requires a writable HOME
                        (setenv "HOME" (getenv "TMPDIR"))
-                       ;; Run test-suite under a dbus session.
-                       (setenv "XDG_DATA_DIRS"  ;for finding org.xfce.Xfconf.service
-                               (string-append #$output "/share:"
-                                              (getenv "XDG_DATA_DIRS")))
+                       ;; dbus-run-session may crash if XDG_DATA_DIRS has too
+                       ;; many entries, maybe related to
+                       ;; https://gitlab.freedesktop.org/dbus/dbus/-/issues/481.
+                       (setenv "XDG_DATA_DIRS"
+                               (string-append
+                                #$output "/share:"
+                                #$(this-package-native-input
+                                   "gsettings-desktop-schemas")
+                                "/share"))
                        ;; Don't fail on missing  '/etc/machine-id'.
                        (setenv "DBUS_FATAL_WARNINGS" "0")
                        (with-directory-excursion (string-append "../at-spi2-core-"
@@ -837,7 +843,8 @@  (define-public at-spi2-core
       ;; atspi-2.pc refers to all these.
       (list dbus glib libx11 libxi libxtst))
      (native-inputs
-      (list gettext-minimal
+      (list findutils
+            gettext-minimal
             `(,glib "bin")
             gobject-introspection
             gsettings-desktop-schemas
@@ -867,25 +874,13 @@  (define-public at-spi2-core-with-documentation
             (add-after 'unpack 'set-documentation-path
               (lambda _
                 ;; Ensure that the cross-references point to the "doc" output.
-                (substitute* "doc/libatspi/meson.build"
-                  (("docpath =.*")
-                   (string-append "docpath = '" #$output:doc
-                                  "/share/gtk-doc/html'\n")))))
-            (add-before 'install 'prepare-doc-directory
-              (lambda _
-                (mkdir-p (string-append #$output:doc "/share"))))
-            #$@(if (%current-target-system)
-                   #~()
-                   #~((add-after 'install 'move-documentation
-                        (lambda _
-                          (copy-recursively
-                           (string-append #$output "/share/gtk-doc")
-                           (string-append #$output:doc "/share/gtk-doc"))
-                          (delete-file-recursively
-                           (string-append #$output "/share/gtk-doc"))))))))))
+                (substitute* "doc/meson.build"
+                  (("docs_dir =.*")
+                   (string-append "docs_dir = '" #$output:doc
+                                  "/share/doc'\n")))))))))
     (native-inputs
      (modify-inputs (package-native-inputs at-spi2-core)
-       (append docbook-xml-4.3 gtk-doc/stable)))
+       (append gi-docgen python python-sphinx)))
     (properties (alist-delete 'hidden?
                               (package-properties at-spi2-core)))))