diff mbox series

[bug#71076,37/81] gnu: Add rust-rustls-platform-verifier-0.3.

Message ID e2a9c14c3a3c11f4ebcce243b7321a8252c31870.1716193123.git.herman@rimm.ee
State New
Headers show
Series Add matrix-conduit and ruma-0.10. | expand

Commit Message

Herman Rimm May 20, 2024, 8:58 a.m. UTC
* gnu/packages/crates-tls.scm (rust-rustls-platform-verifier-0.3): Add
variable.

Change-Id: Idac3b4a08759517923b7a8830ca3ffce6f771aa1
---
 gnu/packages/crates-tls.scm | 56 +++++++++++++++++++++++++++++++++++++
 1 file changed, 56 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/crates-tls.scm b/gnu/packages/crates-tls.scm
index 1069bf7e17..9d2f989bdc 100644
--- a/gnu/packages/crates-tls.scm
+++ b/gnu/packages/crates-tls.scm
@@ -1466,6 +1466,62 @@  (define-public rust-rustls-pki-types-1
     (description "Shared types for the rustls PKI ecosystem.")
     (license (list license:expat license:asl2.0))))
 
+(define-public rust-rustls-platform-verifier-0.3
+  (package
+    (name "rust-rustls-platform-verifier")
+    (version "0.3.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "rustls-platform-verifier" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32
+          "0z8m3j3kpap26gwjaicmrd5096i8140qz1lhjl7pjg6fl5px5w5m"))))
+    (build-system cargo-build-system)
+    (arguments
+     (list
+       #:cargo-test-flags
+       (let ((real-world
+               (lambda (test)
+                 (string-append
+                   "--skip=tests::verification_real_world::tests::"
+                   test))))
+        `(list
+          "--release" "--"
+          ,(string-append "--skip=tests::verification_mock::"
+                          "test_verification_without_mock_root")
+          ,(real-world "_1password_com_valid")
+          ,(real-world "letsencrypt")
+          ,(real-world "my_1password_com_valid")
+          ,(real-world "my_1password_com_valid_no_stapled")
+          ,(real-world "unrelated_chain_not_valid_for_my_1password_com")
+          ,(real-world "unrelated_chain_valid_for_unrelated_domain")
+          ,(real-world "unrelated_domain_invalid")))
+      #:cargo-inputs (list rust-android-logger-0.13
+                           rust-base64-0.21
+                           rust-core-foundation-0.9
+                           rust-core-foundation-sys-0.8
+                           rust-jni-0.19
+                           rust-log-0.4
+                           rust-once-cell-1
+                           rust-rustls-0.23
+                           rust-rustls-native-certs-0.7
+                           rust-rustls-platform-verifier-android-0.1
+                           rust-rustls-webpki-0.102
+                           rust-security-framework-2
+                           rust-security-framework-sys-2
+                           rust-webpki-roots-0.26
+                           rust-winapi-0.3)
+      #:cargo-development-inputs (list rust-rustls-0.23
+                                       rust-webpki-roots-0.26)))
+    (home-page "https://github.com/rustls/rustls-platform-verifier")
+    (synopsis "Verify TLS certs with the operating system verifier")
+    (description
+     "This package provides rustls-platform-verifier, for verifying TLS
+certificates in rustls with the operating system verifier.")
+    (license (list license:expat license:asl2.0))))
+
 (define-public rust-rustls-platform-verifier-android-0.1
   (package
     (name "rust-rustls-platform-verifier-android")