diff mbox series

[bug#70253] gnu: Add kmail-account-wizard.

Message ID e297a7a2f9cf9db23701d5434da851f21ee264bb.1712478828.git.sughosha@disroot.org
State New
Headers show
Series [bug#70253] gnu: Add kmail-account-wizard. | expand

Commit Message

Sughosha April 7, 2024, 8:33 a.m. UTC
* gnu/packages/kde-pim.scm (kmail-account-wizard): New variable.

Change-Id: I1648f588712ccfe5a8e34c16a92f440691d3af18
---
 gnu/packages/kde-pim.scm | 49 ++++++++++++++++++++++++++++++++++++++++
 1 file changed, 49 insertions(+)


base-commit: 188d18fc47f0d38edfe06e3e5834fa8587bd300b
diff mbox series

Patch

diff --git a/gnu/packages/kde-pim.scm b/gnu/packages/kde-pim.scm
index 5780b9dbca..e4ab27467c 100644
--- a/gnu/packages/kde-pim.scm
+++ b/gnu/packages/kde-pim.scm
@@ -1329,6 +1329,55 @@  (define-public kmail
     (license ;; GPL for programs, LGPL for libraries, FDL for documentation
      (list license:gpl2+ license:lgpl2.0+ license:fdl1.2+))))
 
+(define-public kmail-account-wizard
+  (package
+    (name "kmail-account-wizard")
+    (version "23.04.3")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://kde/stable/release-service/" version
+                           "/src/kmail-account-wizard-" version ".tar.xz"))
+       (sha256
+        (base32 "1840zjgrqwk2zgqbb33gl9nvigsrmk5grzvzg5cw116h7lb7z7xx"))))
+    (build-system qt-build-system)
+    (native-inputs
+     (list extra-cmake-modules shared-mime-info))
+    (inputs
+     (list akonadi
+           akonadi-mime
+           kcrash
+           kross
+           kcmutils
+           kdbusaddons
+           kiconthemes
+           kidentitymanagement
+           kimap
+           kitemmodels
+           kldap
+           kmailtransport
+           kmime
+           knewstuff
+           knotifications
+           knotifyconfig
+           kpimcommon
+           kpimtextedit
+           ktextaddons
+           ktexteditor
+           kwallet
+           libkdepim
+           libkleo
+           qtkeychain
+           qtscript
+           qttools-5))
+    (home-page "https://invent.kde.org/pim/kmail-account-wizard")
+    (synopsis "Assistant for the configuration of accounts in KMail")
+    (description
+     "This package provides an assistant for the configuration of accounts in
+KMail.")
+    (license ;;GPL for programs, LGPL for libraries, FDL for documentation
+     (list license:gpl2+ license:lgpl2.0+ license:fdl1.2+))))
+
 (define-public kmailcommon
   (package
     (name "kmailcommon")