[bug#75038,14/14] gnu: Add java-saxon-he-10.

Message ID e288f0f44fb1c7ebd34ce4462752d2d64d1a25dc.1734907748.git.h.goebel@crazy-compilers.com
State New
Headers
Series [bug#75038,01/14] gnu: Add apache-parent-pom-33. |

Commit Message

Hartmut Goebel Dec. 22, 2024, 10:51 p.m. UTC
  * gnu/packages/java-xml.scm (java-saxon-he-10): New variable.
---
 gnu/packages/java-xml.scm | 36 ++++++++++++++++++++++++++++++++++++
 1 file changed, 36 insertions(+)
  

Patch

diff --git a/gnu/packages/java-xml.scm b/gnu/packages/java-xml.scm
index ebae29da80..abfadc9731 100644
--- a/gnu/packages/java-xml.scm
+++ b/gnu/packages/java-xml.scm
@@ -967,3 +967,39 @@  (define-public java-axiom-xml-utils
     (description "This package provides XML utilities used by Apache Axiom
 Weaver, anyhow not depending on depending on the Axiom API.")
     (license license:asl2.0)))
+
+(define-public java-saxon-he-10
+  ;; This is the last version not depending (indirectly via
+  ;; org.xmlresolver.xmlresolver and jing) on itself.
+  (package
+    (name "java-saxon-he")
+    (version "10.9")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "https://repo1.maven.org/maven2/"
+                                  "/" version
+                                  "/Saxon-HE-" version "-sources.jar"))
+              (sha256
+               (base32
+                "17dx6w48ka3d1g20qisvafbc1rmnvfg0vnm8zfz4vkhqfjbkp6j8"))))
+    (build-system ant-build-system)
+    (arguments
+     `(#:tests? #f  ;; has no tests
+       #:jar-name "saxon-HE.jar"))
+    (native-inputs (list unzip))
+    (inputs
+     (list java-axiom-impl
+           java-dom4j
+           java-jdom2
+           java-xom))
+    (propagated-inputs ;; upstream delivers these in its distribution archive
+     (list java-apache-xml-commons-resolver
+           java-jline-2))
+    (home-page "https://www.saxonica.com/")
+    (synopsis "Saxon XSLT Processor")
+    (description "Saxon provides a XSLT 3.0, XQuery 3.1, and XPath 3.1
+processor.  This package provides the open source edition, called
+\"Home Edition (HE)\" for Java.  The Home Edition implements
+aforementioned standards at the basic level of conformance defined by
+W3C.")
+    (license license:mpl2.0)))