diff mbox series

[bug#61845,2/3] gnu: rng-tools: Do not build randstat binary.

Message ID e256018a1dc50c59a0cede30e49a3c965e04631a.1677514269.git.mirai@makinata.eu
State New
Headers show
Series Update rng-tools to 6.16. | expand

Commit Message

Bruno Victal Feb. 27, 2023, 4:14 p.m. UTC
This trivial binary is rarely useful.

* gnu/local.mk (dist_patch_DATA): Register patch.
* gnu/packages/patches/rng-tools-revert-build-randstat.patch: New file.
* gnu/packages/linux.scm (rng-tools)[origin]: Add patch.
---
 gnu/local.mk                                  |  1 +
 gnu/packages/linux.scm                        |  6 ++-
 .../rng-tools-revert-build-randstat.patch     | 49 +++++++++++++++++++
 3 files changed, 55 insertions(+), 1 deletion(-)
 create mode 100644 gnu/packages/patches/rng-tools-revert-build-randstat.patch
diff mbox series

Patch

diff --git a/gnu/local.mk b/gnu/local.mk
index 4ccf015316..4e84cf1b06 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1805,6 +1805,7 @@  dist_patch_DATA =						\
   %D%/packages/patches/restic-0.9.6-fix-tests-for-go1.15.patch	\
   %D%/packages/patches/retroarch-LIBRETRO_DIRECTORY.patch	\
   %D%/packages/patches/r-mixedpower-r2power.patch		\
+  %D%/packages/patches/rng-tools-revert-build-randstat.patch	\
   %D%/packages/patches/rnp-add-version.cmake.patch		\
   %D%/packages/patches/rnp-disable-ruby-rnp-tests.patch		\
   %D%/packages/patches/rnp-unbundle-googletest.patch		\
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index bd180f6325..9ba4b2b119 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -69,6 +69,7 @@ 
 ;;; Copyright © 2022 Hilton Chain <hako@ultrarare.space>
 ;;; Copyright © 2022 Stefan <stefan-guix@vodafonemail.de>
 ;;; Copyright © 2022 Demis Balbach <db@minikn.xyz>
+;;; Copyright © 2023 Bruno Victal <mirai@makinata.eu>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -6592,7 +6593,10 @@  (define-public rng-tools
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "0i00if7xknpm0dhkrm60rxzyyvq0vdibq7dvsd2ncm9pg098qvwj"))))
+                "0i00if7xknpm0dhkrm60rxzyyvq0vdibq7dvsd2ncm9pg098qvwj"))
+              (patches
+               (search-patches "rng-tools-revert-build-randstat.patch"))
+              (patch-flags '("-p0"))))
     (build-system gnu-build-system)
     (arguments
      (list
diff --git a/gnu/packages/patches/rng-tools-revert-build-randstat.patch b/gnu/packages/patches/rng-tools-revert-build-randstat.patch
new file mode 100644
index 0000000000..6402884af0
--- /dev/null
+++ b/gnu/packages/patches/rng-tools-revert-build-randstat.patch
@@ -0,0 +1,49 @@ 
+Source: https://src.fedoraproject.org/rpms/rng-tools/blob/aaca5d6d9c9a50e0d0eed74c67b09863ac37149a/f/2-rt-revert-build-randstat.patch
+
+From de2ee0d8b7e8ad2915165ef941a6ec37442a2fdc Mon Sep 17 00:00:00 2001
+From: Vladis Dronov <vdronov@redhat.com>
+Date: Tue, 6 Jul 2021 14:36:46 +0200
+Subject: [PATCH] Revert "Build randstat binary"
+
+We do not want new and mostly useless randstat binary.
+This reverts commit 2ce93190cb0111fcab2f622a539689d70960643a.
+
+Signed-off-by: Vladis Dronov <vdronov@redhat.com>
+---
+ .gitignore          | 3 +--
+ contrib/Makefile.am | 5 +++--
+ 2 files changed, 4 insertions(+), 4 deletions(-)
+
+diff --git .gitignore .gitignore
+index 943fa2b..5dc334d 100644
+--- .gitignore
++++ .gitignore
+@@ -1,6 +1,6 @@
+ *.a
+ *.o
+-.deps/
++/.deps/
+ /aclocal.m4
+ /ar-lib
+ /autom4te.cache/
+@@ -10,7 +10,6 @@
+ /config.status
+ /config.sub
+ /configure
+-/contrib/randstat
+ /depcomp
+ /install-sh
+ /missing
+diff --git contrib/Makefile.am contrib/Makefile.am
+index a81fb0e..18c4fbc 100644
+--- contrib/Makefile.am
++++ contrib/Makefile.am
+@@ -1,2 +1,3 @@
+-bin_PROGRAMS = randstat
+-randstat_SOURCES = randstat.c
++
++EXTRA_DIST = randstat.c
++
+-- 
+2.26.3
+