[bug#77956,gnome-team,20/23] gnu: Add gst-rtsp-server.

Message ID e244ef0ed3fec8088b14925aaf6f60c7016bce00.1745243273.git.liliana.prikler@gmail.com
State New
Headers
Series Start working on GNOME 48 |

Commit Message

Liliana Marie Prikler April 21, 2025, 1:47 p.m. UTC
  * gnu/packages/gstreamer.scm (gst-rtsp-server): New variable.
---
 gnu/packages/gstreamer.scm | 35 +++++++++++++++++++++++++++++++++++
 1 file changed, 35 insertions(+)
  

Patch

diff --git a/gnu/packages/gstreamer.scm b/gnu/packages/gstreamer.scm
index c5c9ce57d89..29c983f4937 100644
--- a/gnu/packages/gstreamer.scm
+++ b/gnu/packages/gstreamer.scm
@@ -1136,6 +1136,41 @@  (define-public gst-plugins-bad-minimal
 \"bad\" plugin set, essentially containing libraries and the gst-transcoder
 binary, but none of the actual plugins.")))
 
+(define-public gst-rtsp-server
+  (package
+    (name "gst-rtsp-server")
+    (version "1.26.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "https://gstreamer.freedesktop.org/src/" name "/"
+                           name "-" version ".tar.xz"))
+       (sha256
+        (base32 "1g20kf75cq3iqcfal5yyclj0w4ml9pklqmcnjvipagvf94ww10z9"))))
+    (build-system meson-build-system)
+    (arguments
+     (list #:phases
+           #~(modify-phases %standard-phases
+               (add-after 'unpack 'disable-failing-tests
+                 (lambda _
+                   (define failing
+                     (list "client" "media" "mediafactory" "rtspserver"
+                           "sessionmedia" "stream" "onvif" "rtspclientsink"))
+                   (substitute* "tests/check/meson.build"
+                     (("'gst/(.*)',?" all test)
+                      (if (member test failing) "" all))))))))
+    (propagated-inputs
+     (list gstreamer gst-plugins-base gst-plugins-good gst-plugins-bad))
+    (native-inputs (list gobject-introspection
+                         `(,glib "bin")
+                         pkg-config
+                         python-wrapper))
+    (home-page "https://gstreamer.freedesktop.org/")
+    (synopsis "Library for building RTSP servers with GStreamer")
+    (description "This package provides a GStreamer extension to handle
+RTSP connections and messages.")
+    (license license:lgpl2.0+)))
+
 (define-public python-gst
   (package
     (name "python-gst")