diff mbox series

[bug#72244,core-updates] gnu: nss: Run tests with datefudge on 32bit systems.

Message ID e2374bce089af69603fe06357a6a52e0cbd0f980.1721652393.git.mail@cbaines.net
State New
Headers show
Series [bug#72244,core-updates] gnu: nss: Run tests with datefudge on 32bit systems. | expand

Commit Message

Christopher Baines July 22, 2024, 12:46 p.m. UTC
As libfaketime has issues with 64bit time on 32bit systems.

* gnu/packages/nss.scm (nss)[arguments]: Tweak the gtests.sh script and use
datefudge rather than faketime on 32bit systems.
[native-inputs]: Use datetime rather than libfaketime on 32bit systems.

Change-Id: Ice97b2dc36049d6ad0a7d4154defd40b0ba41c94
---
 gnu/packages/nss.scm | 19 +++++++++++++++++--
 1 file changed, 17 insertions(+), 2 deletions(-)


base-commit: ffb56a574f03e5fb7d60ea46cc883bee7878f414

Comments

Ludovic Courtès July 26, 2024, 9:14 a.m. UTC | #1
Christopher Baines <mail@cbaines.net> skribis:

> As libfaketime has issues with 64bit time on 32bit systems.
>
> * gnu/packages/nss.scm (nss)[arguments]: Tweak the gtests.sh script and use
> datefudge rather than faketime on 32bit systems.
> [native-inputs]: Use datetime rather than libfaketime on 32bit systems.
>
> Change-Id: Ice97b2dc36049d6ad0a7d4154defd40b0ba41c94

I pushed a variant as 21fe1e077aa77488bd413ef3255973c60d7468fe, as
discussed in <https://issues.guix.gnu.org/72239>.

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/nss.scm b/gnu/packages/nss.scm
index 49276817ae..93c594d5e7 100644
--- a/gnu/packages/nss.scm
+++ b/gnu/packages/nss.scm
@@ -39,6 +39,7 @@  (define-module (gnu packages nss)
   #:use-module (gnu packages check)
   #:use-module (gnu packages crates-io)
   #:use-module (gnu packages compression)
+  #:use-module (gnu packages time)
   #:use-module (gnu packages perl)
   #:use-module (gnu packages sqlite))
 
@@ -211,11 +212,21 @@  (define-public nss
                     (substitute* "nss/tests/dbtests/dbtests.sh"
                       ((" -lt 5") " -lt 50"))
 
+                    #$@(if (target-64bit?)
+                           #~()
+                           ;; Not sure why, but this avoids some tests failing
+                           ;; when using datefudge
+                           #~((substitute* "nss/tests/gtests/gtests.sh"
+                                (("cd \"\\$\\(dirname \"\\$1\"\\)\"") ""))))
+
                     ;; The "PayPalEE.cert" certificate expires every six months,
                     ;; leading to test failures:
                     ;; <https://bugzilla.mozilla.org/show_bug.cgi?id=609734>.  To
                     ;; work around that, set the time to roughly the release date.
-                    (invoke "faketime" "2024-01-23" "./nss/tests/all.sh"))
+                    (invoke #$(if (target-64bit?)
+                                  "faketime"
+                                  "datefudge")
+                            "2024-01-23" "./nss/tests/all.sh"))
                   (format #t "test suite not run~%"))))
           (replace 'install
             (lambda* (#:key outputs #:allow-other-keys)
@@ -240,7 +251,11 @@  (define-public nss
                 (copy-recursively (string-append obj "/lib") lib)))))))
     (inputs (list sqlite zlib))
     (propagated-inputs (list nspr))               ;required by nss.pc.
-    (native-inputs (list perl libfaketime which)) ;for tests
+    (native-inputs (list perl
+                         (if (target-64bit?)
+                             libfaketime
+                             datefudge)
+                         which)) ;for tests
 
     ;; The NSS test suite takes around 48 hours on Loongson 3A (MIPS) when
     ;; another build is happening concurrently on the same machine.