diff mbox series

[bug#49434,2/2] gnu: bootstrap-tarballs: Use guile-3.0 bootstrap tarball.

Message ID e2095dd8f2c183252734d2c639c7e5c65d9feb0e.1625558726.git.efraim@flashner.co.il
State Accepted
Headers show
Series Update bootstrap tarballs | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Efraim Flashner July 6, 2021, 8:14 a.m. UTC
* gnu/packages/make-bootstrap.scm (%guile-bootstrap-tarball): Use
guile-3.0.
(%guile-static-stripped): Remove variable.
---
 gnu/packages/make-bootstrap.scm | 10 +++-------
 1 file changed, 3 insertions(+), 7 deletions(-)

Comments

Ludovic Courtès July 6, 2021, 2:38 p.m. UTC | #1
Efraim Flashner <efraim@flashner.co.il> skribis:

> * gnu/packages/make-bootstrap.scm (%guile-bootstrap-tarball): Use
> guile-3.0.
> (%guile-static-stripped): Remove variable.

Same comment regarding the commit’s subject line.

[...]

>  (define %guile-3.0-static-stripped
> -  ;; A stripped static Guile 3.0 binary, for use in initrds.
> +  ;; A stripped static Guile 3.0 binary, for use in initrds
> +  ;; and during bootstrap.

Maybe drop “-3.0” from the variable name?

It’ss worth checking whether this impacts the initrd code; “make
check-system TESTS=basic” should catch regressions.

Otherwise LGTM, thanks!

Ludo’.
Efraim Flashner July 8, 2021, 6:43 a.m. UTC | #2
On Tue, Jul 06, 2021 at 04:38:08PM +0200, Ludovic Courtès wrote:
> Efraim Flashner <efraim@flashner.co.il> skribis:
> 
> > * gnu/packages/make-bootstrap.scm (%guile-bootstrap-tarball): Use
> > guile-3.0.
> > (%guile-static-stripped): Remove variable.
> 
> Same comment regarding the commit’s subject line.
> 
> [...]
> 
> >  (define %guile-3.0-static-stripped
> > -  ;; A stripped static Guile 3.0 binary, for use in initrds.
> > +  ;; A stripped static Guile 3.0 binary, for use in initrds
> > +  ;; and during bootstrap.
> 
> Maybe drop “-3.0” from the variable name?
> 
> It’ss worth checking whether this impacts the initrd code; “make
> check-system TESTS=basic” should catch regressions.
> 
> Otherwise LGTM, thanks!
> 
> Ludo’.

QEMU runs as PID 18
connected to QEMU's monitor
read QEMU monitor prompt
connected to guest REPL
%%%% Starting test basic  (Writing full log to "basic.log")
marionette is ready

;;; (services (console-font-tty1 term-tty5 file-systems loopback term-tty2 term-auto console-font-tty3 term-tty4 term-tty3 nscd marionette term-tty1 root user)
# of expected passes      27
# of skipped tests        1
successfully built /gnu/store/b5qh7nmw16xsn8h8da8vvy7pqqbkfxnj-basic.drv
/gnu/store/jjd04fjpsibwp7iyj3jggiam9z7av934-basic

I'll push it as a separate commit.
diff mbox series

Patch

diff --git a/gnu/packages/make-bootstrap.scm b/gnu/packages/make-bootstrap.scm
index ff9376e91f..d66acc2e70 100644
--- a/gnu/packages/make-bootstrap.scm
+++ b/gnu/packages/make-bootstrap.scm
@@ -55,7 +55,6 @@ 
             %mes-bootstrap-tarball
             %bootstrap-tarballs
 
-            %guile-static-stripped
             %guile-3.0-static-stripped))
 
 ;;; Commentary:
@@ -799,12 +798,9 @@  for `sh' in $PATH, and without nscd, and with static NSS modules."
     (outputs '("out"))
     (synopsis "Minimal statically-linked and relocatable Guile")))
 
-(define %guile-static-stripped
-  ;; A stripped static Guile binary, for use during bootstrap.
-  (make-guile-static-stripped %guile-static))
-
 (define %guile-3.0-static-stripped
-  ;; A stripped static Guile 3.0 binary, for use in initrds.
+  ;; A stripped static Guile 3.0 binary, for use in initrds
+  ;; and during bootstrap.
   (make-guile-static-stripped
    (make-guile-static guile-3.0
                       '("guile-2.2-default-utf8.patch"
@@ -867,7 +863,7 @@  for `sh' in $PATH, and without nscd, and with static NSS modules."
 
 (define %guile-bootstrap-tarball
   ;; A tarball with the statically-linked, relocatable Guile.
-  (tarball-package %guile-static-stripped))
+  (tarball-package %guile-3.0-static-stripped))
 
 (define %mescc-tools-bootstrap-tarball
   ;; A tarball with statically-linked MesCC binary seed.