diff mbox series

[bug#54457,2/9] gnu: Add libnetfilter-cttimeout

Message ID e1f8c78f-ee0c-21f8-dc74-2eaa0a16db71@gmail.com
State Accepted
Headers show
Series None | expand

Commit Message

fesoj000 March 21, 2022, 9:20 p.m. UTC
* gnu/packages/linux.scm (libnetfilter-cttimeout): New variable.
---
  gnu/packages/linux.scm | 28 ++++++++++++++++++++++++++++
  1 file changed, 28 insertions(+)

Comments

M March 23, 2022, 7:38 p.m. UTC | #1
fesoj000 schreef op ma 21-03-2022 om 22:20 [+0100]:
> +   (inputs (list libmnl pkg-config))

pkg-config probably shouldn't be an input (native-input is fine
though).
diff mbox series

Patch

diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 037cb12e3f..7ea3776057 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -7274,6 +7274,34 @@  (define-public libnetfilter-conntrack
                               "libnetfilter_conntrack/index.html"))
     (license license:gpl2+)))
  
+(define-public libnetfilter-cttimeout
+  (package
+   (name "libnetfilter_cttimeout")
+   (version "1.0.0")
+   (source
+    (origin
+     (method url-fetch)
+     (uri (string-append "https://netfilter.org/projects/"
+                         "libnetfilter_cttimeout/files/"
+                         "libnetfilter_cttimeout-"
+                         version ".tar.bz2"))
+     (sha256
+      (base32
+       "1fpyz1zlvcq80244knvyvy87909xjqlj02lmw8yblz2m9xsi5axf"))))
+   (build-system gnu-build-system)
+   (supported-systems (filter target-linux? %supported-systems))
+   (native-inputs (list pkg-config))
+   (inputs (list libmnl pkg-config))
+   (synopsis "Library for kernel connection tracking timeout infrastructure")
+   (description "libnetfilter_cttimeout is the userspace library that provides
+the programming interface to the fine-grain connection tracking timeout
+infrastructure. With this library, you can create, update and delete timeout
+policies that can be attached to traffic flows. This library is used by
+conntrack-tools.")
+   (home-page (string-append "https://netfilter.org/projects/"
+                             "libnetfilter_cttimeout/index.html"))
+   (license license:gpl2)))
+
  (define-public proot
    (package
      (name "proot")