[bug#77347] gnu: Remove mia.
Commit Message
The package has no dependent packages. It does not build any more since
May 2023, and has not seen a newer release since the currently packaged
release from 2020.
* gnu/packages/image-processing.scm (mia): Delete variable.
Change-Id: I62556d2690903b6171b5ff752094310fb989fc03
---
This should be removed on or after April 28.
gnu/packages/image-processing.scm | 56 -------------------------------
1 file changed, 56 deletions(-)
base-commit: 1a5b520abb751ac6d390f476755f7a77450de515
@@ -206,62 +206,6 @@ (define-public dcmtk
"A union of the Apache 2.0 licence and various non-copyleft
licences similar to the Modified BSD licence."))))
-(define-public mia
- (package
- (name "mia")
- (version "2.4.7")
- (source (origin
- (method url-fetch)
- (uri (string-append "mirror://sourceforge/mia/mia/"
- (version-major+minor version)
- "/mia-" version ".tar.xz"))
- (sha256
- (base32
- "0qpcd3n26q52dpyibm11f5l6cgscdr54p2jish39gc3p1f5h3ws1"))
- (patches (search-patches "mia-fix-boost-headers.patch"
- "mia-vtk9.patch"
- "mia-vtk92.patch"
- "mia-vtk-version.patch"))))
- (build-system cmake-build-system)
- (arguments
- `(#:configure-flags
- (list "-DMIA_CREATE_NIPYPE_INTERFACES=OFF"
- "-DCMAKE_CXX_FLAGS=-fpermissive")))
- (inputs
- (list boost
- dcmtk
- doxygen
- eigen
- fftw
- fftwf
- gsl
- gts
- hdf5
- itpp
- libjpeg-turbo
- libpng
- libtiff
- libxml2
- libxml++
- maxflow
- niftilib
- nlopt
- openexr-2
- python-lxml
- vtk))
- (native-inputs
- (list pkg-config
- python-wrapper))
- (home-page "https://mia.sourceforge.net")
- (synopsis "Toolkit for gray scale medical image analysis")
- (description "MIA provides a combination of command line tools, plug-ins,
-and libraries that make it possible run image processing tasks interactively
-in a command shell and to prototype using the shell's scripting language. It
-is built around a plug-in structure that makes it easy to add functionality
-without compromising the original code base and it makes use of a wide variety
-of external libraries that provide additional functionality.")
- (license license:gpl3+)))
-
(define-public opencolorio
(package
(name "opencolorio")