diff mbox series

[bug#64149,2/2] gnu: patman: Add python-u-boot-pylib to inputs.

Message ID e1a6018e5f50c446f91fe8b48b49022ab3f2adad.1688788818.git.maxim.cournoyer@gmail.com
State New
Headers show
Series [bug#64149,1/2] gnu: Add python-u-boot-pylib. | expand

Commit Message

Maxim Cournoyer July 8, 2023, 4:03 a.m. UTC
* gnu/packages/bootloaders.scm (patman) [inputs]: Add python-u-boot-pylib.
---
 gnu/packages/bootloaders.scm | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Vagrant Cascadian July 8, 2023, 11:21 p.m. UTC | #1
On 2023-07-08, Maxim Cournoyer wrote:
> * gnu/packages/bootloaders.scm (patman) [inputs]: Add python-u-boot-pylib.
> ---
>  gnu/packages/bootloaders.scm | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/gnu/packages/bootloaders.scm b/gnu/packages/bootloaders.scm
> index c1a76ab90e..789248afeb 100644
> --- a/gnu/packages/bootloaders.scm
> +++ b/gnu/packages/bootloaders.scm
> @@ -869,7 +869,7 @@ (define-public patman
>            (add-after 'unpack 'chdir
>              (lambda _
>                (chdir "tools/patman"))))))
> -    (inputs (list python-pygit2 python-requests))
> +    (inputs (list python-pygit2 python-requests python-u-boot-pylib))
>      (synopsis "Patch automation tool")
>      (description "Patman is a patch automation script which:
>  @itemize
> -- 
> 2.40.1

This was not sufficient to get patman building again:

starting phase `sanity-check'                                                                                                       validating 'patch-manager' /gnu/store/d22rsfa7pr8ff6ai1hp72qjljiyayzrx-patman-2023.07-rc6/lib/python3.10/site-packages
...checking requirements: OK                                                                                                        ...trying to load module patman: OK                                                                                                 ...trying to load endpoint console_scripts patman: ERROR:
Traceback (most recent call last):                                                                                                    File "/gnu/store/rlf99syqlc9kyf76rba3sbxsafszf017-python-u-boot-pylib-2023.07-rc6/lib/python3.10/site-packages/u_boot_pylib/command.py", line 95, in run_pipe
    last_pipe = cros_subprocess.Popen(cmd, cwd=cwd, **kwargs)                                                                         File "/gnu/store/rlf99syqlc9kyf76rba3sbxsafszf017-python-u-boot-pylib-2023.07-rc6/lib/python3.10/site-packages/u_boot_pylib/cros_subprocess.py", line 83, in __init__
    super(Popen, self).__init__(args, stdin=stdin,                                                                                    File "/gnu/store/kj6wzba6p192baizq99b489rs8bynpn7-python-3.10.7/lib/python3.10/subprocess.py", line 969, in __init__                  self._execute_child(args, executable, preexec_fn, close_fds,
  File "/gnu/store/kj6wzba6p192baizq99b489rs8bynpn7-python-3.10.7/lib/python3.10/subprocess.py", line 1845, in _execute_child
    raise child_exception_type(errno_num, err_msg, err_filename)
FileNotFoundError: [Errno 2] No such file or directory: 'git'                                                                       
live well,
  vagrant
Vagrant Cascadian July 9, 2023, 2:36 a.m. UTC | #2
On 2023-07-08, Vagrant Cascadian wrote:
> On 2023-07-08, Maxim Cournoyer wrote:
> starting phase `sanity-check'                                                                                                       validating 'patch-manager' /gnu/store/d22rsfa7pr8ff6ai1hp72qjljiyayzrx-patman-2023.07-rc6/lib/python3.10/site-packages
> ...checking requirements: OK                                                                                                        ...trying to load module patman: OK                                                                                                 ...trying to load endpoint console_scripts patman: ERROR:
> Traceback (most recent call last):                                                                                                    File "/gnu/store/rlf99syqlc9kyf76rba3sbxsafszf017-python-u-boot-pylib-2023.07-rc6/lib/python3.10/site-packages/u_boot_pylib/command.py", line 95, in run_pipe
>     last_pipe = cros_subprocess.Popen(cmd, cwd=cwd, **kwargs)                                                                         File "/gnu/store/rlf99syqlc9kyf76rba3sbxsafszf017-python-u-boot-pylib-2023.07-rc6/lib/python3.10/site-packages/u_boot_pylib/cros_subprocess.py", line 83, in __init__
>     super(Popen, self).__init__(args, stdin=stdin,                                                                                    File "/gnu/store/kj6wzba6p192baizq99b489rs8bynpn7-python-3.10.7/lib/python3.10/subprocess.py", line 969, in __init__                  self._execute_child(args, executable, preexec_fn, close_fds,
>   File "/gnu/store/kj6wzba6p192baizq99b489rs8bynpn7-python-3.10.7/lib/python3.10/subprocess.py", line 1845, in _execute_child
>     raise child_exception_type(errno_num, err_msg, err_filename)
> FileNotFoundError: [Errno 2] No such file or directory: 'git'

Adding git to inputs or native inputs avoided that part... but still
ends with an error:

...trying to load endpoint console_scripts patman: ERROR:
Traceback (most recent call last):
  File "/gnu/store/iqsjkp55pcx5bfcp2jm9yj5rlx9a0whd-sanity-check.py", line 89, in <module>
    ep.load()
  File "/gnu/store/dy3xh053ahkhrp2jamggq8cpsyvp8mg0-python-3.10.7/lib/python3.10/site-packages/pkg_resources/__init__.py", line 2471
, in load
    return self.resolve()
  File "/gnu/store/dy3xh053ahkhrp2jamggq8cpsyvp8mg0-python-3.10.7/lib/python3.10/site-packages/pkg_resources/__init__.py", line 2477
, in resolve
    module = __import__(self.module_name, fromlist=['__name__'], level=0)
  File "/gnu/store/v76an72qxvclc5qy46bddin3rcljka2f-patman-2023.07-rc6/lib/python3.10/site-packages/patman/__main__.py", line 47, in
 <module>
    parser.add_argument('-p', '--project', default=project.detect_project(),
  File "/gnu/store/v76an72qxvclc5qy46bddin3rcljka2f-patman-2023.07-rc6/lib/python3.10/site-packages/patman/project.py", line 19, in
detect_project
    top_level = gitutil.get_top_level()
  File "/gnu/store/v76an72qxvclc5qy46bddin3rcljka2f-patman-2023.07-rc6/lib/python3.10/site-packages/patman/gitutil.py", line 627, in
 get_top_level
    return command.output_one_line('git', 'rev-parse', '--show-toplevel')
  File "/gnu/store/rlf99syqlc9kyf76rba3sbxsafszf017-python-u-boot-pylib-2023.07-rc6/lib/python3.10/site-packages/u_boot_pylib/comman
d.py", line 128, in output_one_line
    result = run_pipe([cmd], capture=True, oneline=True,
  File "/gnu/store/rlf99syqlc9kyf76rba3sbxsafszf017-python-u-boot-pylib-2023.07-rc6/lib/python3.10/site-packages/u_boot_pylib/comman
d.py", line 112, in run_pipe
    raise Exception("Error running '%s'" % user_pipestr)
Exception: Error running 'git rev-parse --show-toplevel'
error: in phase 'sanity-check': uncaught exception:


It seems to be running git on some repository that presumably does not
exist?


live well,
  vagrant
Maxim Cournoyer July 10, 2023, 4:01 a.m. UTC | #3
Hi Vagrant,

Vagrant Cascadian <vagrant@debian.org> writes:

> On 2023-07-08, Maxim Cournoyer wrote:
>> * gnu/packages/bootloaders.scm (patman) [inputs]: Add python-u-boot-pylib.
>> ---
>>  gnu/packages/bootloaders.scm | 2 +-
>>  1 file changed, 1 insertion(+), 1 deletion(-)
>>
>> diff --git a/gnu/packages/bootloaders.scm b/gnu/packages/bootloaders.scm
>> index c1a76ab90e..789248afeb 100644
>> --- a/gnu/packages/bootloaders.scm
>> +++ b/gnu/packages/bootloaders.scm
>> @@ -869,7 +869,7 @@ (define-public patman
>>            (add-after 'unpack 'chdir
>>              (lambda _
>>                (chdir "tools/patman"))))))
>> -    (inputs (list python-pygit2 python-requests))
>> +    (inputs (list python-pygit2 python-requests python-u-boot-pylib))
>>      (synopsis "Patch automation tool")
>>      (description "Patman is a patch automation script which:
>>  @itemize
>> -- 
>> 2.40.1
>
> This was not sufficient to get patman building again:

Oh, indeed, seems I hadn't gone to that point in my testing.

> starting phase `sanity-check'                                                                                                       validating 'patch-manager' /gnu/store/d22rsfa7pr8ff6ai1hp72qjljiyayzrx-patman-2023.07-rc6/lib/python3.10/site-packages
> ...checking requirements: OK                                                                                                        ...trying to load module patman: OK                                                                                                 ...trying to load endpoint console_scripts patman: ERROR:
> Traceback (most recent call last):                                                                                                    File "/gnu/store/rlf99syqlc9kyf76rba3sbxsafszf017-python-u-boot-pylib-2023.07-rc6/lib/python3.10/site-packages/u_boot_pylib/command.py", line 95, in run_pipe
>     last_pipe = cros_subprocess.Popen(cmd, cwd=cwd, **kwargs)                                                                         File "/gnu/store/rlf99syqlc9kyf76rba3sbxsafszf017-python-u-boot-pylib-2023.07-rc6/lib/python3.10/site-packages/u_boot_pylib/cros_subprocess.py", line 83, in __init__
>     super(Popen, self).__init__(args, stdin=stdin,                                                                                    File "/gnu/store/kj6wzba6p192baizq99b489rs8bynpn7-python-3.10.7/lib/python3.10/subprocess.py", line 969, in __init__                  self._execute_child(args, executable, preexec_fn, close_fds,
>   File "/gnu/store/kj6wzba6p192baizq99b489rs8bynpn7-python-3.10.7/lib/python3.10/subprocess.py", line 1845, in _execute_child
>     raise child_exception_type(errno_num, err_msg, err_filename)
> FileNotFoundError: [Errno 2] No such file or directory: 'git'                                                                       
I've made a patch to patman so that it falls back to use the current
working directory when git or its metadata is unavailable, but I still
got this error in the sanity-check phase:

--8<---------------cut here---------------start------------->8---
phase `check' succeeded after 0.0 seconds
starting phase `sanity-check'
usage: iqsjkp55pcx5bfcp2jm9yj5rlx9a0whd-sanity-check.py [-h] [-b BRANCH]
                                                        [-c COUNT] [-e END]
                                                        [-D] [-p PROJECT]
                                                        [-P PATCHWORK_URL]
                                                        [-s START] [-v] [-H]
                                                        {send,status} ...
iqsjkp55pcx5bfcp2jm9yj5rlx9a0whd-sanity-check.py: error: argument cmd: invalid choice: '/gnu/store/caxygz92s8zf7lk7a58d2yr873hzx46w-patman-2023.07-rc6/lib/python3.10/site-packages' (choose from 'send', 'status')
validating 'patch-manager' /gnu/store/caxygz92s8zf7lk7a58d2yr873hzx46w-patman-2023.07-rc6/lib/python3.10/site-packages
...checking requirements: OK
...trying to load module patman: OK
...trying to load endpoint console_scripts patman: failed to retrieve top level via git; using CWD
failed to retrieve top level via git; using CWD
error: in phase 'sanity-check': uncaught exception:
%exception #<&invoke-error program: "python" arguments: ("/gnu/store/iqsjkp55pcx5bfcp2jm9yj5rlx9a0whd-sanity-check.py" "/gnu/store/caxygz92s8zf7lk7a58d2yr873hzx46w-patman-2023.07-rc6/lib/python3.10/site-packages") exit-status: 2 term-signal: #f stop-signal: #f> 
phase `sanity-check' failed after 0.2 seconds
--8<---------------cut here---------------end--------------->8---

Perhaps for the time being deleting that phase with an explanatory
comment would be the best course of action.
diff mbox series

Patch

diff --git a/gnu/packages/bootloaders.scm b/gnu/packages/bootloaders.scm
index c1a76ab90e..789248afeb 100644
--- a/gnu/packages/bootloaders.scm
+++ b/gnu/packages/bootloaders.scm
@@ -869,7 +869,7 @@  (define-public patman
           (add-after 'unpack 'chdir
             (lambda _
               (chdir "tools/patman"))))))
-    (inputs (list python-pygit2 python-requests))
+    (inputs (list python-pygit2 python-requests python-u-boot-pylib))
     (synopsis "Patch automation tool")
     (description "Patman is a patch automation script which:
 @itemize