diff mbox series

[bug#40171] gnu: Add lv2toweb.

Message ID e182b319fa8017a5d150d6e5572405509e6f0c97.camel@zrythm.org
State Accepted
Headers show
Series [bug#40171] gnu: Add lv2toweb. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

Alexandros Theodotou March 21, 2020, 7:41 p.m. UTC
Hi,

This patch adds lv2toweb, an HTML document generator for lv2 plugins
based on their metadata.

Thanks,
Alex

Comments

Ludovic Courtès March 23, 2020, 9:45 a.m. UTC | #1
Hi Alexandros,

Alexandros Theodotou <alex@zrythm.org> skribis:

> From aca67249cab61ef85ad164c8f87d7eb4f68b98b3 Mon Sep 17 00:00:00 2001
> From: Alexandros Theodotou <alex@zrythm.org>
> Date: Sat, 21 Mar 2020 19:38:41 +0000
> Subject: [PATCH] gnu: Add lv2toweb.
>
> * gnu/packages/audio.scm (lv2toweb): New variable.

Applied, thanks!

Ludo’.
diff mbox series

Patch

From aca67249cab61ef85ad164c8f87d7eb4f68b98b3 Mon Sep 17 00:00:00 2001
From: Alexandros Theodotou <alex@zrythm.org>
Date: Sat, 21 Mar 2020 19:38:41 +0000
Subject: [PATCH] gnu: Add lv2toweb.

* gnu/packages/audio.scm (lv2toweb): New variable.
---
 gnu/packages/audio.scm | 37 +++++++++++++++++++++++++++++++++++++
 1 file changed, 37 insertions(+)

diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index f3edd21c69..bad6f4a18d 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -78,6 +78,7 @@ 
   #:use-module (gnu packages libusb)
   #:use-module (gnu packages linux)
   #:use-module (gnu packages llvm)
+  #:use-module (gnu packages man)
   #:use-module (gnu packages maths)
   #:use-module (gnu packages mp3) ;taglib
   #:use-module (gnu packages multiprecision)
@@ -4081,3 +4082,39 @@  given plugin and its UI(s) match up with the provided metadata and adhere
 to well-known best practices.")
     (home-page "https://open-music-kontrollers.ch/lv2/lv2lint/")
     (license license:artistic2.0)))
+
+(define-public lv2toweb
+  (package
+    (name "lv2toweb")
+    (version "0.4")
+    (source
+      (origin
+        (method git-fetch)
+        (uri (git-reference
+               (url "https://github.com/x42/lv2toweb")
+               (commit (string-append "v" version))))
+        (file-name (git-file-name name version))
+        (sha256
+          (base32
+            "007aysqvgkf25za8nkmyd5g9kp1zla460dcpidlj5xg1zc3fcdfi"))))
+    (build-system gnu-build-system)
+    (arguments
+    `(#:tests? #f  ; no "check" target
+      #:make-flags (list "CC=gcc"
+                         (string-append "PREFIX=" (assoc-ref %outputs "out")))
+      #:phases
+      (modify-phases %standard-phases
+        (delete 'configure))))
+    (inputs
+      `(("jalv", jalv)
+        ("lilv", lilv)))
+    (native-inputs
+      `(("help2man", help2man)
+        ("pkg-config", pkg-config)))
+    (synopsis "Documentation generator for LV2 plugins")
+    (description
+      "lv2toweb allows the user to create an xhtml page with information
+about the given LV2 plugin, provided that the plugin and its UI(s) match up
+with the provided metadata and adhere to well-known best practices.")
+    (home-page "https://github.com/x42/lv2toweb")
+    (license (list license:isc license:gpl2))))
-- 
2.25.1