diff mbox series

[bug#69990] gnu: llama-cpp: mark as tunable per CPU architecture

Message ID e17975e8b72d1b2cc11554b5b177e3b7bd044701.1711314349.git.john@fremlin.org
State New
Headers show
Series [bug#69990] gnu: llama-cpp: mark as tunable per CPU architecture | expand

Commit Message

John Fremlin March 24, 2024, 9:05 p.m. UTC
* gnu/packages/machine-learning.scm (llama-cpp): add tunable property.

Otherwise llama-cpp will use FMA4 instructions leading to SIGILL on even
recent AMD chips, that do not support them.

Change-Id: Ie69086cb9c3ed609d6bf73b0abf0c6f9df7220b1
---
 gnu/packages/machine-learning.scm | 1 +
 1 file changed, 1 insertion(+)


base-commit: 28bc0e870b4d48b8e3e773382bb0e999df2e3611
diff mbox series

Patch

diff --git a/gnu/packages/machine-learning.scm b/gnu/packages/machine-learning.scm
index 003be7e3c6..79fa425de3 100644
--- a/gnu/packages/machine-learning.scm
+++ b/gnu/packages/machine-learning.scm
@@ -538,6 +538,7 @@  (define-public llama-cpp
          (file-name (git-file-name name version))
          (sha256
           (base32 "1ag1jash84hasz10h0piw72a8ginm8kzvhihbzzljz96gq2kjm88"))))
+      (properties '((tunable? . #true)))
       (build-system cmake-build-system)
       (arguments
        (list