diff mbox

[bug#36146,0/4] Add various Emacs packages

Message ID e168995d-79fd-42c4-a1d8-ec76db7356ca@www.fastmail.com
State Accepted
Headers show

Commit Message

Alex Griffin June 11, 2019, 12:31 a.m. UTC
I've attached an updated patch series that uses git references instead of melpa urls.

Comments

Oleg Pykhalov June 13, 2019, 8:43 p.m. UTC | #1
"Alex Griffin" <a@ajgrf.com> writes:

> I've attached an updated patch series that uses git references instead
> of melpa urls.

Thank you.

>> Also running tests for ‘emacs-elfeed-org’ would be a great improvement.
> 
> Elfeed-org uses Cask for testing, just like a great many other Emacs
> packages. As far as I can tell, though, it hasn't been packaged for
> Guix yet.

Cask is used only for installation of different Emacs versions. I added
a required ‘xtest’ package and found in ‘Makefile’ that tests suite
could be run by calling ‘ert-runner’ with “-L org-mode/lisp” arguments.

Also changed version to 0.1 because no upstream doesn't have a release.

Pushed all patches to master.

Oleg.
diff mbox

Patch

From d5264382911e7b77a76211e57c705d21505042a4 Mon Sep 17 00:00:00 2001
From: Alex Griffin <a@ajgrf.com>
Date: Sun, 9 Jun 2019 09:02:04 -0500
Subject: [PATCH 4/4] gnu: Add emacs-solaire-mode.

* gnu/packages/emacs-xyz.scm (emacs-solaire-mode): New variable.
---
 gnu/packages/emacs-xyz.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 03ccd61f1c..d18db93361 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -4093,6 +4093,29 @@  of sixteen colors suitable for a wide range of applications.  Base16 is not a
 single theme but a set of guidelines with numerous implementations.")
     (license license:expat)))
 
+(define-public emacs-solaire-mode
+  (package
+    (name "emacs-solaire-mode")
+    (version "1.0.9")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/hlissner/emacs-solaire-mode.git")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "011m4r7s6i9lgjymh7jgq5jwwrpz4vmpvp3c8d4ix96v5hi04kzg"))))
+    (build-system emacs-build-system)
+    (home-page "https://github.com/hlissner/emacs-solaire-mode")
+    (synopsis "Change background of file-visiting buffers in Emacs")
+    (description
+     "@code{solaire-mode} is inspired by editors which visually distinguish
+code-editing windows from sidebars, popups, terminals, ecetera.  It changes the
+background of file-visiting buffers (and certain aspects of the UI) to make
+them easier to distinguish from other, less important buffers.")
+    (license license:expat)))
+
 (define-public emacs-prescient
   (package
     (name "emacs-prescient")
-- 
2.22.0