diff mbox series

[bug#65814,06/19] gnu: python-cdflib: Fix version detection.

Message ID e14d0aa72c2b2d9d7c1e57271f3e9f596f337460.1694125610.git.sharlatanus@gmail.com
State New
Headers show
Series gnu: Astronomy 2023/08 updates. | expand

Commit Message

Sharlatan Hellseher Sept. 7, 2023, 10:32 p.m. UTC
* gnu/packages/astronomy.scm (python-cdflib): Fix version detection
during build Wheel package.
[arguments]: Add new phase 'set-env-version.
[native-inputs]: Add python-setuptools-scm.
---
 gnu/packages/astronomy.scm | 5 +++++
 1 file changed, 5 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 95b29ec2ea..335c075a68 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -1657,6 +1657,10 @@  (define-public python-cdflib
     (arguments
      (list #:phases
            #~(modify-phases %standard-phases
+               (add-before 'build 'set-env-version
+                 (lambda _
+                   (setenv "SETUPTOOLS_SCM_PRETEND_VERSION"
+                           #$version)))
                (add-before 'check 'set-home-env
                  (lambda _
                    (setenv "HOME" (getcwd)))))))
@@ -1668,6 +1672,7 @@  (define-public python-cdflib
            python-pytest
            python-pytest-cov
            python-pytest-remotedata
+           python-setuptools-scm
            python-xarray))
     (home-page "https://github.com/MAVENSDC/cdflib")
     (synopsis "Python library to deal with NASA's CDF astronmical data format")