diff mbox series

[bug#52524] gnu: Add qdirstat

Message ID e13e0f56-c8d7-7e84-246a-8bd78e826872@cock.li
State Accepted
Headers show
Series [bug#52524] gnu: Add qdirstat | expand

Commit Message

Justin Veilleux Dec. 15, 2021, 9:26 p.m. UTC
This is a patch to add the very useful qdirstat tool.

Cheers!
diff mbox series

Patch

From 0f7482ea3f4fba98c5c76a27fab91a3e68c6ed1d Mon Sep 17 00:00:00 2001
From: terramorpha <terramorpha@cock.li>
Date: Wed, 15 Dec 2021 16:21:06 -0500
Subject: [PATCH] gnu: Add qdirstat.

* gnu/packages/disk.scm (qdirstat): New variable
---
 gnu/packages/disk.scm | 41 +++++++++++++++++++++++++++++++++++++++++
 1 file changed, 41 insertions(+)

diff --git a/gnu/packages/disk.scm b/gnu/packages/disk.scm
index d74d941ee0..b61577a25a 100644
--- a/gnu/packages/disk.scm
+++ b/gnu/packages/disk.scm
@@ -21,6 +21,7 @@ 
 ;;; Copyright © 2021 Michael Rohleder <mike@rohleder.de>
 ;;; Copyright © 2021 Mathieu Othacehe <othacehe@gnu.org>
 ;;; Copyright © 2021 Brice Waegeneire <brice@waegenei.re>
+;;; Copyright © 2021 Justin Veilleux <terramorpha@cock.li>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -66,10 +67,12 @@  (define-module (gnu packages disk)
   #:use-module (gnu packages ncurses)
   #:use-module (gnu packages nss)
   #:use-module (gnu packages perl)
+  #:use-module (gnu packages perl-web)
   #:use-module (gnu packages pkg-config)
   #:use-module (gnu packages popt)
   #:use-module (gnu packages python)
   #:use-module (gnu packages python-xyz)
+  #:use-module (gnu packages qt)
   #:use-module (gnu packages readline)
   #:use-module (gnu packages samba)
   #:use-module (gnu packages serialization)
@@ -1330,3 +1333,41 @@  (define-public duc
 Duc comes with console utilities, ncurses and X11 user interfaces and a CGI
 wrapper for disk usage querying and visualisation.")
     (license license:lgpl3+)))
+
+(define-public qdirstat
+  (package
+    (name "qdirstat")
+    (version "1.8")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/shundhammer/qdirstat")
+                    (commit version)))
+              (sha256
+               (base32
+                "079rmy3j0442y5gjh6la6w1j6jaw83wklamrf19yxi20zsm99xs7"))))
+    (arguments
+     `(#:phases (modify-phases %standard-phases
+                  (replace 'configure
+                    (lambda* (#:key outputs #:allow-other-keys)
+                      (system* "qmake"
+                               (string-append "INSTALL_PREFIX="
+                                              (assoc-ref outputs "out"))))))))
+    (build-system gnu-build-system)
+    (inputs
+     (list
+      perl
+      qtbase-5
+      zlib))
+    (propagated-inputs
+     (list
+      perl
+      perl-uri-escape))
+    (synopsis "Storage utilisation vizualization tool")
+    (description
+     "QDirStat is a graphical application to show where your disk space has
+gone and to help you to clean it up.")
+
+    (home-page "https://github.com/shundhammer/qdirstat")
+    (license license:gpl2)))
+
-- 
2.34.0