[bug#75675,v1,1/2] gnu: Add python-shxparser.

Message ID e13a5200ea409fb5750b2d97ec4f8dc28c707d28.1741620975.git.mail@pisemsky.site
State New
Headers
Series [bug#75675,v1,1/2] gnu: Add python-shxparser. |

Commit Message

Evgeny Pisemsky March 10, 2025, 3:36 p.m. UTC
  * gnu/packages/python-xyz.scm (python-shxparser): New variable.

Change-Id: Iaa4bdc216f0e06595237d6fb8e5ee138797605bc
---
 gnu/packages/python-xyz.scm | 20 ++++++++++++++++++++
 1 file changed, 20 insertions(+)


base-commit: 519fc51b6ecfe9ac9f2fa2f4ae052ab1984eed22
  

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 9f2829c4a8..ae644d80fd 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -34576,6 +34576,26 @@  (define-public python-dparse
     (description "This package provides a parser for Python dependency files.")
     (license license:expat)))
 
+(define-public python-shxparser
+  (package
+    (name "python-shxparser")
+    (version "0.0.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "shxparser" version))
+       (sha256
+        (base32 "0w7j5ywskandp91v74966pw1pvq9d5zrx5gkjcn84xi8wsyf8hc5"))))
+    (build-system pyproject-build-system)
+    (native-inputs (list python-svgelements python-setuptools python-wheel))
+    (home-page "https://github.com/tatarize/shxparser")
+    (synopsis "SHX line font parser")
+    (description
+     "This is a pure python parser for SHX Hershey font files that are an
+AutoCad format which can encode single line fonts.  This format is
+used for many CNC and laser operations.")
+    (license license:expat)))
+
 (define-public python-dpath
   (package
     (name "python-dpath")