[bug#76480,48/51] gnu: python-poliastro: Disable more failing tests.

Message ID e138b51b6252d9f105beadc0ac2505019960f052.1740173176.git.sharlatanus@gmail.com
State New
Headers
Series Astro update 2025/02 |

Commit Message

Sharlatan Hellseher Feb. 21, 2025, 9:49 p.m. UTC
  * gnu/packages/astronomy.scm (python-poliastro) [arguments]
<test-flags>: Ignore all tests from "test_czml.py" as all failed, skip
one more test.

Change-Id: Ie10688a0dbdeb25a0fe89417bc60839d44e6057c
---
 gnu/packages/astronomy.scm | 14 ++++++--------
 1 file changed, 6 insertions(+), 8 deletions(-)
  

Patch

diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 2b7e0e8b5d7..683e9b90bc4 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -4852,14 +4852,12 @@  (define-public python-poliastro
               ;; TODO: Review failing tests later when any upstream
               ;; suggestions are provided:
               ;; https://github.com/poliastro/poliastro/issues/1618
-              "-k" (string-append "not test_czml_add_trajectory"
-                                  " and not test_czml_custom_packet"
-                                  " and not test_czml_ground_station"
-                                  " and not test_czml_groundtrack"
-                                  " and not test_czml_preamble"
-                                  ;; This fails with "ufunc 'isfinite' not
-                                  ;; supported for the input types"
-                                  " and not test_porkchop_plotting"))
+              "--ignore=tests/test_czml.py"
+              "-k" (string-append
+                    ;; This fails with "ufunc 'isfinite' not
+                    ;; supported for the input types"
+                    "not test_porkchop_plotting"
+                    " and not test_maneuver_constructor_raises_error_if_invalid_delta_v"))
       #:phases
       #~(modify-phases %standard-phases
          (add-after 'unpack 'relax-requirements