diff mbox series

[bug#46536] Fix build of materialdecoration.

Message ID e128b4ef-76ec-8f24-d3ac-ed1d6f709fc8@raghavgururajan.name
State Accepted
Headers show
Series [bug#46536] Fix build of materialdecoration. | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Raghav Gururajan Feb. 15, 2021, 5:41 p.m. UTC
Hi Leo!

>> * gnu/packages/cmake.scm (cmake-shared) [git-version]: Update to
>> 1.1.0-32.
> The git-version field doesn't actually change.  You could annotate
> [commit] and [revision] separately, but it usually makes sense to just
> say "update to <commit hash>".
> 
> * gnu/packages/qt.scm (materialdecoration) [git-version]: Update to
>> 1.1.0-9.
> Same here.
> 
>> [arguments]<#:phases>['remove-3rdparty]: New phase.
> Should that be a snippet instead?
> 
>> <#:phases>['remove-3rdparty]: New phase.
> As above.
> 
>> [arguments]<#:configure-flags>[-DCMAKE_CXX_FLAGS]: New flag.
> That's a bit too much nesting.
> "[arguments]<#:configure-flags: Add -DCMAKE_CXX_FLAGS"
> is probably a better choice.
> 
> Otherwise LGTM.

Thanks for the review. I have attached revised patches.

Regards,
RG.

Comments

Leo Prikler Feb. 15, 2021, 6:08 p.m. UTC | #1
Hi Raghav,

Am Montag, den 15.02.2021, 12:41 -0500 schrieb Raghav Gururajan:
> Thanks for the review. I have attached revised patches.
Thanks for the patches.  I've pushed them upstream, so I'll be closing
this and 46314.

Regards,
Leo
Raghav Gururajan Feb. 15, 2021, 6:09 p.m. UTC | #2
Hi Leo!

> Thanks for the patches.  I've pushed them upstream, so I'll be closing
> this and 46314.

Thank you!

Regards,
RG.
diff mbox series

Patch

From 921c99fd1402d96b24f551c191898d7f92986b40 Mon Sep 17 00:00:00 2001
From: Raghav Gururajan <rg@raghavgururajan.name>
Date: Mon, 15 Feb 2021 11:19:32 -0500
Subject: [PATCH 2/2] gnu: materialdecoration: Update to 1.1.0-9.

* gnu/packages/qt.scm (materialdecoration): Update to 1.1.0-9.
[source]: Add snippet to remove bundled sources.
[arguments]<#:configure-flags>: Add -DCMAKE_CXX_FLAGS.
[inputs]: Add libxkbcommon.
---
 gnu/packages/qt.scm | 72 ++++++++++++++++++++++++++++-----------------
 1 file changed, 45 insertions(+), 27 deletions(-)

diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 4fbb157600..11e69ff5db 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -161,34 +161,52 @@  window managers, that don't provide Qt integration by themselves.")
     (license license:bsd-2)))
 
 (define-public materialdecoration
-  (package
-    (name "materialdecoration")
-    (version "1.1.0")
-    (source
-     (origin
-       (method git-fetch)
-       (uri
-        (git-reference
-         (url "https://github.com/lirios/materialdecoration.git")
-         (commit "2079487116c6c794af3a15452342a69293039b46")))
-       (file-name
-        (git-file-name name version))
-       (sha256
-        (base32 "1pczmxbmnsgj9s1g6ap55qq2q4ccibcnhsw9b6cl5rzgc48izy06"))))
-    (build-system qt-build-system)
-    (native-inputs
-     `(("cmake-shared" ,cmake-shared)
-       ("extra-cmake-modules" ,extra-cmake-modules)
-       ("pkg-config" ,pkg-config)))
-    (inputs
-     `(("qtbase" ,qtbase)
-       ("qtwayland" ,qtwayland)
-       ("wayland" ,wayland)))
-    (synopsis "Material Decoration for Qt")
-    (description "MaterialDecoration is a client-side decoration for Qt
+  (let ((commit "6a5de23f2e5162fbee39d16f938473ff970a2ec0")
+        (revision "9"))
+    (package
+      (name "materialdecoration")
+      (version
+       (git-version "1.1.0" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri
+          (git-reference
+           (url "https://github.com/lirios/materialdecoration.git")
+           (commit commit)))
+         (file-name
+          (git-file-name name version))
+         (sha256
+          (base32 "1zdrcb39fhhmn76w8anv1dnspz26pdl6izmj1mlm02aza4y8ffp4"))
+         (modules '((guix build utils)
+                    (ice-9 ftw)
+                    (srfi srfi-1)))
+         (snippet
+          `(begin
+             (delete-file-recursively "cmake/3rdparty")))))
+      (build-system qt-build-system)
+      (arguments
+       `(#:tests? #f                    ; No target
+         #:configure-flags
+         (list
+          (string-append "-DCMAKE_CXX_FLAGS=-I"
+                         (assoc-ref %build-inputs "qtbase")
+                         "/include/qt5/QtXkbCommonSupport/"
+                         ,(package-version qtbase)))))
+      (native-inputs
+       `(("cmake-shared" ,cmake-shared)
+         ("extra-cmake-modules" ,extra-cmake-modules)
+         ("pkg-config" ,pkg-config)))
+      (inputs
+       `(("qtbase" ,qtbase)
+         ("qtwayland" ,qtwayland)
+         ("wayland" ,wayland)
+         ("xkbcommon" ,libxkbcommon)))
+      (synopsis "Material Decoration for Qt")
+      (description "MaterialDecoration is a client-side decoration for Qt
 applications on Wayland.")
-    (home-page "https://github.com/lirios/materialdecoration")
-    (license license:lgpl3+)))
+      (home-page "https://github.com/lirios/materialdecoration")
+      (license license:lgpl3+))))
 
 (define-public grantlee
   (package
-- 
2.30.0