diff mbox series

[bug#52721] gnu: python-pydata-sphinx-theme: Fix build.

Message ID e0d96e33c82390f4bb8d6a77e8c6a7d17f8f8d10.1640125976.git.avityazev@posteo.org
State Accepted
Headers show
Series [bug#52721] gnu: python-pydata-sphinx-theme: Fix build. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Aleksandr Vityazev Dec. 21, 2021, 10:34 p.m. UTC
Hi,

the build fails because a package is required python-docutils < 0.17.


--8<---------------cut here---------------start------------->8---
ERROR: Could not find a version that satisfies the requirement docutils<0.17 (from versions: none)
ERROR: No matching distribution found for docutils<0.17
error: Command '['/gnu/store/3282r97il61j9jkv2aaifa3nwdylzfsv-python-wrapper-3.9.6/bin/python', '-m', 'pip', '--disable-pip-version-check', 'wheel', '--no-deps', '-w', '/tmp/guix-build-python-pydata-sphinx-theme-0.6.3.drv-0/tmpqhg_sgru', '--quiet', 'docutils<0.17']' returned non-zero exit status 1.
--8<---------------cut here---------------end--------------->8---



* gnu/packages/sphinx (python-pydata-sphinx-theme):
[native-inputs]: Replace python-docutils with python-docutils-0.15.
---
 gnu/packages/sphinx.scm | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)

Comments

M Dec. 22, 2021, 10:53 a.m. UTC | #1
Hi,

> the build fails because a package is required python-docutils < 0.17.

Is python-docutils<0.17 truly required, or are the version requirements
in the source code overly strict? If it's the latter, you could patch
the source code to relax the requirements.

The latter happens often, because library developers often don't know
in advance whether the library is compatible with future versions of
the dependencies.

Greetings,
Maxime.
diff mbox series

Patch

diff --git a/gnu/packages/sphinx.scm b/gnu/packages/sphinx.scm
index 3ac5b5e22c..957c4dc9c4 100644
--- a/gnu/packages/sphinx.scm
+++ b/gnu/packages/sphinx.scm
@@ -18,6 +18,7 @@ 
 ;;; Copyright © 2021 Vinicius Monego <monego@posteo.net>
 ;;; Copyright © 2021 Hugo Lecomte <hugo.lecomte@inria.fr>
 ;;; Copyright © 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2021 Aleksandr Vityazev <avityazev@posteo.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -919,7 +920,7 @@  (define-public python-pydata-sphinx-theme
      (list python-beautifulsoup4))
     (native-inputs
      (list python-beautifulsoup4
-           python-docutils
+           python-docutils-0.15
            python-jupyter-sphinx
            python-numpy
            python-numpydoc