diff mbox series

[bug#59356,5/5] gnu: Add go-github-com-makeworld-the-better-one-gemget.

Message ID e0c9b5e4-f170-8921-f5c7-ea7bfed840e9@disroot.org
State New
Headers show
Series None | expand

Commit Message

Adam Faiz Nov. 18, 2022, 11:54 a.m. UTC
From 66d7d381f376168c385b2e8808e50e3b7f8b17d7 Mon Sep 17 00:00:00 2001
From: AwesomeAdam54321 <adam.faiz@disroot.org>
Date: Fri, 18 Nov 2022 09:17:41 +0800
Subject: [PATCH] gnu: Add go-github-com-makeworld-the-better-one-gemget.

* gnu/packages/web.scm (go-github-com-makeworld-the-better-one-gemget): 
New variable.
---
  gnu/packages/web.scm | 30 ++++++++++++++++++++++++++++++
  1 file changed, 30 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index d2c406915c..b1762ee9f3 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -7400,6 +7400,36 @@  (define-public perl-html-tidy
  in Perl but is not nearly as capable as @code{HTML::Tidy}.")
      (license license:artistic2.0)))

+(define-public go-github-com-makeworld-the-better-one-gemget
+  (package
+    (name "go-github-com-makeworld-the-better-one-gemget")
+    (version "1.8.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/makeworld-the-better-one/gemget")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1ma07wlki4pgmw19yk4dzyxa6blk8ciz3wb46ipbfz7k361lhsry"))))
+    (build-system go-build-system)
+    (inputs
+     (list go-github-com-dustin-go-humanize
+           go-github-com-spf13-pflag
+           go-github-com-makeworld-the-better-one-go-gemini
+           go-golang-org-x-net
+           go-golang-org-x-text
+           go-github-com-schollz-progressbar))
+    (arguments
+     (list #:import-path "github.com/makeworld-the-better-one/gemget"))
+    (synopsis "Command line downloader for the Gemini protocol")
+    (description
+     "Gemget is a command line downloader for the Gemini protocol.
+It works well with streams and can print headers for debugging as well.")
+    (home-page "https://github.com/makeworld-the-better-one/gemget")
+    (license license:expat)))
+
  (define-public geomyidae
    (package
      (name "geomyidae")