diff mbox series

[bug#71780,v2,7/7] gnu: Add hydroxide.

Message ID e0a2150b04535a9cadf65023404494fde6198338.1719696984.git.woshilapin@tuziwo.info
State New
Headers show
Series [bug#71780,v2,1/7] gnu: go-github-com-emersion-go-pgpmail: Update to 0.2.1. | expand

Commit Message

woshilapin June 29, 2024, 9:37 p.m. UTC
* gnu/packages/mail.scm (hydroxide): New variable.

Change-Id: Ic20d8d3d22afc4a580094bed64d0aa5059a1a9cf
---
 gnu/packages/mail.scm | 37 +++++++++++++++++++++++++++++++++++++
 1 file changed, 37 insertions(+)

Comments

woshilapin June 29, 2024, 9:43 p.m. UTC | #1
Hi Oleg,

I tried to use etc/commiter.scm with some success, but it was breaking on some of the Update commits: I took inspiration on some of the existing commits to improve them. In the end, I believe it's better than it was.

Don't hesitate to point me to some more tooling or documentation, since this is my first experience with guix packaging, and with 'git send-email', there might still be a lot of things that I don't do correctly.

Thank you very much for taking some time reviewing these.
--
Jean SIMARD aka woshilapin
diff mbox series

Patch

diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index de6d21e7cc..dd813baef6 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -56,6 +56,7 @@ 
 ;;; Copyright © 2023 Arjan Adriaanse <arjan@adriaan.se>
 ;;; Copyright © 2023 Wilko Meyer <w@wmeyer.eu>
 ;;; Copyright © 2024 Benjamin Slade <slade@lambda-y.net>
+;;; Copyright © 2024 Jean Simard <woshilapin@tuziwo.info>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -5121,3 +5122,39 @@  (define-public aerc
     ;; <https://lists.sr.ht/~rjarry/aerc-devel/%3Cb5cb213a7d0c699a886971658c2476
     ;; 1073eb2391%40disroot.org%3E>
     (license license:gpl3+)))
+
+(define-public hydroxide
+  (package
+    (name "hydroxide")
+    (version "0.2.28")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/emersion/hydroxide")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1a7qga9qxwcdjimra9d9jnkds1iwh2sqk6241p4di6awli9zksv1"))))
+    (build-system go-build-system)
+    (arguments
+     (list
+      #:import-path "github.com/emersion/hydroxide/cmd/hydroxide"
+      #:unpack-path "github.com/emersion/hydroxide"))
+    (inputs (list go-github-com-protonmail-go-crypto
+                  go-github-com-boltdb-bolt
+                  go-github-com-emersion-go-bcrypt
+                  go-github-com-emersion-go-imap
+                  go-github-com-emersion-go-mbox
+                  go-github-com-emersion-go-message
+                  go-github-com-emersion-go-smtp-v0.18
+                  go-github-com-emersion-go-vcard
+                  go-github-com-emersion-go-webdav
+                  go-golang-org-x-crypto
+                  go-golang-org-x-term))
+    (home-page "https://github.com/emersion/hydroxide")
+    (synopsis "Third-party, open-source ProtonMail bridge")
+    (description "A third-party, open-source ProtonMail bridge.
+     For power users only, designed to run on a server.
+     hydroxide supports CardDAV, IMAP and SMTP.")
+    (license license:expat)))