diff mbox series

[bug#69074] gnu: Add python-cle.

Message ID e095b802e1762753a03b1d3199d68f127ca71a93.1707749005.git.soeren@soeren-tempel.net
State New
Headers show
Series [bug#69074] gnu: Add python-cle. | expand

Commit Message

Sören Tempel Feb. 12, 2024, 2:58 p.m. UTC
From: Sören Tempel <soeren@soeren-tempel.net>

* gnu/packages/python-xyz.scm (python-cle): New variable.
---
 gnu/packages/python-xyz.scm | 27 ++++++++++++++++++++++++++-
 1 file changed, 26 insertions(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index d46963c481..6ab83b7dc7 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -32304,6 +32304,31 @@  (define-public python-opcodes
 and BMI2).")
       (license license:bsd-2))))
 
+(define-public python-cle
+  (package
+    (name "python-cle")
+    (version "9.2.46")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "cle" version))
+       (sha256
+        (base32 "0mswv9gd2p2ws7zfsshqv5ybbj27wkdwakdcknq4vsrx9ry9k4yc"))))
+    (build-system pyproject-build-system)
+    (arguments
+     (list
+      #:tests? #f))
+    (propagated-inputs (list python-pefile python-pyelftools python-pyvex
+                             python-sortedcontainers))
+    (native-inputs (list python-cffi))
+    (home-page "https://github.com/angr/cle")
+    (synopsis "Python loader for binaries and their associated libraries")
+    (description
+     "CLE loads binaries and their associated libraries, resolves
+imports and provides an abstraction of process memory the same way as if
+it was loader by the operating system's loader.")
+    (license license:bsd-2)))
+
 (define-public python-pyvex
   (package
     (name "python-pyvex")
@@ -32325,7 +32350,7 @@  (define-public python-pyvex
                          (with-directory-excursion "tests"
                            (invoke "python" "-m" "unittest")))))
 
-                   (add-before 'build 'set-cc-native
+                   (add-before 'build 'set-cc
                      (lambda _
                        (setenv "CC" "gcc")
                        (setenv "CC_NATIVE" "gcc"))))))