diff mbox series

[bug#38957] gnu: Add python-pywinrm

Message ID e05fddba6a470c0c26aa41881591fada73395d6d.camel@zrythm.org
State Accepted
Headers show
Series [bug#38957] gnu: Add python-pywinrm | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed

Commit Message

Alexandros Theodotou Jan. 8, 2020, 3:02 p.m. UTC
Hi Brett,

Thanks for taking a look at this.

On Mon, 2020-01-06 at 03:22 -0600, Brett Gilio wrote:
> Could you please split these package
> definitions into a patch series, rather than as a single patch? This
> is
> preferable for how our Git workflow is utilized so that we can keep
> track of packages individually in the commit log if we ever need to
> go
> back and look at our records.

Attaching the split patches.

Thanks,
Alex

Comments

Christopher Baines March 22, 2020, 11:39 p.m. UTC | #1
Alexandros Theodotou <alex@zrythm.org> writes:

> Hi Brett,
>
> Thanks for taking a look at this.
>
> On Mon, 2020-01-06 at 03:22 -0600, Brett Gilio wrote:
>> Could you please split these package
>> definitions into a patch series, rather than as a single patch? This
>> is
>> preferable for how our Git workflow is utilized so that we can keep
>> track of packages individually in the commit log if we ever need to
>> go
>> back and look at our records.
>
> Attaching the split patches.

Hi Alexandros,

Sorry it's been so long to look more at these patches. I've had a look
today and they look good to me. I had to fix some merge conflicts, and I
changed the indentation in a couple of places, so I've sent the changed
patches to the bug now.

I'll let others take a look, and merge in a few days if it's all looking
good.

Thanks,

Chris
Christopher Baines March 26, 2020, 7:15 p.m. UTC | #2
Christopher Baines <mail@cbaines.net> writes:

> Alexandros Theodotou <alex@zrythm.org> writes:
>
>> Hi Brett,
>>
>> Thanks for taking a look at this.
>>
>> On Mon, 2020-01-06 at 03:22 -0600, Brett Gilio wrote:
>>> Could you please split these package
>>> definitions into a patch series, rather than as a single patch? This
>>> is
>>> preferable for how our Git workflow is utilized so that we can keep
>>> track of packages individually in the commit log if we ever need to
>>> go
>>> back and look at our records.
>>
>> Attaching the split patches.
>
> Hi Alexandros,
>
> Sorry it's been so long to look more at these patches. I've had a look
> today and they look good to me. I had to fix some merge conflicts, and I
> changed the indentation in a couple of places, so I've sent the changed
> patches to the bug now.
>
> I'll let others take a look, and merge in a few days if it's all looking
> good.

I've gone ahead and pushed these patches to master as
9b0c95cc6877229da0816e7b962090966a8577de.

Thanks Alexandros!
diff mbox series

Patch

From d89f6bdb5559c60d568749ab864e8503bf2e91f4 Mon Sep 17 00:00:00 2001
From: Alexandros Theodotou <alex@zrythm.org>
Date: Wed, 8 Jan 2020 14:56:52 +0000
Subject: [PATCH 2/4] gnu: Add python-ntlm-auth.

* gnu/packages/python-crypto.scm (python-ntlm-auth): New variable.
---
 gnu/packages/python-crypto.scm | 29 +++++++++++++++++++++++++++++
 1 file changed, 29 insertions(+)

diff --git a/gnu/packages/python-crypto.scm b/gnu/packages/python-crypto.scm
index a60ee6289d..61e1107248 100644
--- a/gnu/packages/python-crypto.scm
+++ b/gnu/packages/python-crypto.scm
@@ -1138,6 +1138,35 @@  package provides a tool to securely sign firmware images for booting by
 MCUboot.")
     (license license:expat)))
 
+(define-public python-ntlm-auth
+  (package
+    (name "python-ntlm-auth")
+    (version "1.4.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "ntlm-auth" version))
+       (sha256
+        (base32
+         "16mavidki4ma5ip8srqalr19gz4f5yn3cnmmgps1fmgfr24j63rm"))))
+    (build-system python-build-system)
+    (propagated-inputs
+     `(("python-cryptography" ,python-cryptography)))
+    (home-page "https://github.com/jborean93/ntlm-auth")
+    (synopsis
+      "Calculates NTLM Authentication codes")
+    (description
+      "This library handles the low-level details of NTLM authentication for
+use in authenticating with a service that uses NTLM.  It will create and parse
+the 3 different message types in the order required and produce a base64
+encoded value that can be attached to the HTTP header.
+
+The goal of this library is to offer full NTLM support including signing and
+sealing of messages as well as supporting MIC for message integrity and the
+ability to customise and set limits on the messages sent.  Please see Features
+and Backlog for a list of what is and is not currently supported.")
+    (license license:expat)))
+
 (define-public python-kerberos
   (package
     (name "python-kerberos")
-- 
2.24.1