[bug#77371,11/12] gnu: Add python-vector.
Commit Message
* gnu/packages/python-science.scm (python-vector): New variable.
Change-Id: I77d72b0c18a0bc215cb2198ce5447e587b13d0fe
---
gnu/packages/python-science.scm | 29 +++++++++++++++++++++++++++++
1 file changed, 29 insertions(+)
@@ -1207,6 +1207,35 @@ (define-public python-decaylanguage
given to programs dedicated to amplitude analyses.")
(license license:bsd-3)))
+(define-public python-vector
+ (package
+ (name "python-vector")
+ (version "1.6.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "vector" version))
+ (sha256
+ (base32 "1r6ncbdnak75nvyhn9rkmgg08l6ggxyvb5ikqrv5zlskwl62v62r"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list
+ ;; This file requires python-papermill (not yet packaged).
+ #:test-flags #~(list "--ignore" "tests/test_notebooks.py")))
+ (propagated-inputs (list python-numpy python-packaging))
+ (native-inputs (list python-awkward
+ python-hatch-vcs
+ python-hatchling
+ python-pytest
+ python-sympy))
+ (home-page "https://github.com/scikit-hep/vector")
+ (synopsis "Arrays of 2D, 3D, and Lorentz vectors")
+ (description "Vector is a Python library for 2D and 3D spatial vectors, as
+well as 4D space-time vectors. It is especially intended for performing
+geometric calculations on arrays of vectors, rather than one vector at a time
+in a Python @code{for} loop.")
+ (license license:bsd-3)))
+
(define-public python-trimesh
(package
(name "python-trimesh")