[bug#77371,11/12] gnu: Add python-vector.

Message ID e05ae0750fcf1ba3a45f25045fbb7691dfe668f7.1743288280.git.monego@posteo.net
State New
Headers
Series Add packages from the scikit-hep project |

Commit Message

Vinicius Monego March 29, 2025, 11:01 p.m. UTC
  * gnu/packages/python-science.scm (python-vector): New variable.

Change-Id: I77d72b0c18a0bc215cb2198ce5447e587b13d0fe
---
 gnu/packages/python-science.scm | 29 +++++++++++++++++++++++++++++
 1 file changed, 29 insertions(+)
  

Patch

diff --git a/gnu/packages/python-science.scm b/gnu/packages/python-science.scm
index c2f23c8d55..41504b457e 100644
--- a/gnu/packages/python-science.scm
+++ b/gnu/packages/python-science.scm
@@ -1207,6 +1207,35 @@  (define-public python-decaylanguage
 given to programs dedicated to amplitude analyses.")
     (license license:bsd-3)))
 
+(define-public python-vector
+  (package
+    (name "python-vector")
+    (version "1.6.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "vector" version))
+       (sha256
+        (base32 "1r6ncbdnak75nvyhn9rkmgg08l6ggxyvb5ikqrv5zlskwl62v62r"))))
+    (build-system pyproject-build-system)
+    (arguments
+     (list
+      ;; This file requires python-papermill (not yet packaged).
+      #:test-flags #~(list "--ignore" "tests/test_notebooks.py")))
+    (propagated-inputs (list python-numpy python-packaging))
+    (native-inputs (list python-awkward
+                         python-hatch-vcs
+                         python-hatchling
+                         python-pytest
+                         python-sympy))
+    (home-page "https://github.com/scikit-hep/vector")
+    (synopsis "Arrays of 2D, 3D, and Lorentz vectors")
+    (description "Vector is a Python library for 2D and 3D spatial vectors, as
+well as 4D space-time vectors.  It is especially intended for performing
+geometric calculations on arrays of vectors, rather than one vector at a time
+in a Python @code{for} loop.")
+    (license license:bsd-3)))
+
 (define-public python-trimesh
   (package
     (name "python-trimesh")