diff mbox series

[bug#55155] gnu: add r-piton

Message ID e0394afbed415435035934b8c7487eb7@posteo.net
State New
Headers show
Series [bug#55155] gnu: add r-piton | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

kyle April 27, 2022, 4:07 p.m. UTC
Dear Guix,

I would like the CRAN R package piton included in Guix. Please see the 
attached patch.

Kyle

Comments

Ricardo Wurmus Dec. 29, 2022, 9:32 p.m. UTC | #1
I just applied the patch in issue #55380, which also adds r-piton.  I
did not realize that you submitted this patch before that one.

Since the package definition now exist I’m closing this issue.

Thank you for your patch anyway!
diff mbox series

Patch

From ac6ddfb2e3f2461955d1bc22de6d00bd8cda3fd0 Mon Sep 17 00:00:00 2001
From: Kyle Andrews <kyle.c.andrews@gmail.com>
Date: Wed, 27 Apr 2022 08:33:38 -0400
Subject: [PATCH] gnu: add r-piton.

---
 gnu/packages/cran.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)

diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 21cfca3102..fd49d87fbf 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -33123,3 +33123,25 @@  (define-public r-zoeppritz
 coefficients or scattering amplitudes, for seismological P and S-waves at an
 interface.")
     (license license:gpl2+)))
+
+(define-public r-piton
+  (package
+   (name "r-piton")
+   (version "1.0.0")
+   (source
+    (origin
+     (method url-fetch)
+     (uri (cran-uri "piton" version))
+     (sha256
+      (base32 "1krf6zi238m275nxjlpyayv8y2drbgs2kg19dpkqm0lmlz5y5ar8"))))
+   (properties `((upstream-name . "piton")))
+   (build-system r-build-system)
+   (propagated-inputs (list r-rcpp))
+   (home-page "https://github.com/Ironholds/piton")
+   (synopsis "Parsing Expression Grammars in Rcpp")
+   (description
+    "This package provides a wrapper around the 'Parsing Expression Grammar Template
+Library', a C++11 library for generating Parsing Expression Grammars, that makes
+it accessible within Rcpp.  With this, developers can implement their own
+grammars and easily expose them in R packages.")
+   (license license:expat)))
-- 
2.35.1