[bug#76600,v2] gnu: Add python-edalize.
Commit Message
* gnu/packages/electronics.scm (python-edalize): New variable.
Change-Id: I993421a9eb20b2124acf28d0a8187d3e9845ae77
---
gnu/packages/electronics.scm | 33 +++++++++++++++++++++++++++++++++
1 file changed, 33 insertions(+)
base-commit: a9530d181d02e73896779cebd0687cf9cffb2c82
@@ -570,6 +570,39 @@ (define-public uhdm
VPI Interface, Elaborator, Serialization, Visitor and Listener.")
(license license:asl2.0)))
+(define-public python-edalize
+ (package
+ (name "python-edalize")
+ (version "0.6.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/olofk/edalize/")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1gfysk6wj3mxndyzma604i3y2lkfn1im0bdmzxv5rn4x2nyk68sc"))))
+ (build-system pyproject-build-system)
+ (arguments
+ `(#:phases (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? inputs outputs #:allow-other-keys)
+ (when tests?
+ ;; Skip erroneous tests
+ (invoke "pytest" "tests" "-vv" "-k"
+ (string-append "not test_gatemate "
+ "and not test_vivado_edif_netlist "
+ "and not test_xcelium " "and not test_vcs"))))))))
+ (native-inputs (list python-setuptools python-wheel python-jinja2
+ python-pytest))
+ (home-page "https:/test_vivado_edif_netlist/github.com/olofk/edalize/")
+ (synopsis "Python Library for interacting with EDA tools")
+ (description
+ "Edalize can create project files for supported tools and run them in
+batch or GUI mode.")
+ (license license:bsd-2)))
+
(define-public python-vsg
(package
(name "python-vsg")