diff mbox series

[bug#50655] gnu: Add falltergeist.

Message ID dv9Hjga0NEuzqzAGksrTJMOWCsIuWOZvR1tHMJUzgRnqx1UaomwwQ_6IR533Qs09GUSSr1hahalJFjBXIcUr7Y67nKHTin5qcTyt7MmGVpI=@protonmail.com
State Accepted
Headers show
Series [bug#50655] gnu: Add falltergeist. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

phodina Sept. 18, 2021, 10:05 a.m. UTC
* gnu/packages/games.scm (falltergeist): New variable.

--
2.32.0

Comments

Xinglu Chen Sept. 20, 2021, 12:36 p.m. UTC | #1
On Sat, Sep 18 2021, phodina via Guix-patches via wrote:

> * gnu/packages/games.scm (falltergeist): New variable.
>
> diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
> index c39770c260..ca0e46749c 100644
> --- a/gnu/packages/games.scm
> +++ b/gnu/packages/games.scm
> @@ -1133,6 +1133,34 @@ regular @command{cat}, but it also adds terminal escape codes between
>  characters and lines resulting in a rainbow effect.")
>        (license license:wtfpl2))))
>
> +(define-public falltergeist
> +  (package
> +    (name "falltergeist")
> +    (version "0.3.1")
> +    (source (origin
> +              (method git-fetch)
> +              (uri (git-reference
> +                    (url "https://github.com/falltergeist/falltergeist")
> +                    (commit version)))
> +              (file-name (git-file-name name version))
> +              (sha256
> +               (base32
> +                "05cg58i2g32wbmrvmdsicic8xs83gld3qr1p7r4lnlckcl1l7dy4"))))
> +    (build-system cmake-build-system)
> +    (arguments
> +     `(#:tests? #f))

What’s the reason for disabling tests?

> +    (native-inputs `(("pkg-config" ,pkg-config)))
> +    (inputs `(("sdl" ,(sdl-union (list sdl2
> +                                       sdl2-image
> +                                       sdl2-mixer)))
> +              ("glew" ,glew)
> +              ("glm" ,glm)))
> +    (synopsis "Opensource crossplatform Fallout 2 game engine")
> +    (description "Opensource crossplatform Fallout 2 game engine.  Game data
> +should be placed in ~/.local/share/falltergeist.")

The description should consist of one or more full sentences (the first
sentence is lacking a subject).  The path should use Texinfo syntax:

  @file{~/.local/share/filltergeist}


> +    (home-page "https://falltergeist.org/")
> +    (license license:gpl3)))

‘license.txt’ says gpl3+.

Could you send an updated patch?
diff mbox series

Patch

diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index c39770c260..ca0e46749c 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -1133,6 +1133,34 @@  regular @command{cat}, but it also adds terminal escape codes between
 characters and lines resulting in a rainbow effect.")
       (license license:wtfpl2))))

+(define-public falltergeist
+  (package
+    (name "falltergeist")
+    (version "0.3.1")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/falltergeist/falltergeist")
+                    (commit version)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "05cg58i2g32wbmrvmdsicic8xs83gld3qr1p7r4lnlckcl1l7dy4"))))
+    (build-system cmake-build-system)
+    (arguments
+     `(#:tests? #f))
+    (native-inputs `(("pkg-config" ,pkg-config)))
+    (inputs `(("sdl" ,(sdl-union (list sdl2
+                                       sdl2-image
+                                       sdl2-mixer)))
+              ("glew" ,glew)
+              ("glm" ,glm)))
+    (synopsis "Opensource crossplatform Fallout 2 game engine")
+    (description "Opensource crossplatform Fallout 2 game engine.  Game data
+should be placed in ~/.local/share/falltergeist.")
+    (home-page "https://falltergeist.org/")
+    (license license:gpl3)))
+
 (define-public foobillard++
   ;; Even though this latest revision is old already, stable release is
   ;; lagging way behind it, and has issues with textures rendering.