[bug#75420,python-team,01/11] gnu: Add python-expandvars.
Commit Message
* gnu/packages/python-xyz.scm (python-expandvars): New variable.
Change-Id: Ib6441555754189be7283e51873ef6306a6896294
---
gnu/packages/python-xyz.scm | 22 ++++++++++++++++++++++
1 file changed, 22 insertions(+)
@@ -159,6 +159,7 @@
;;; Copyright © 2024 Aaron Covrig <aaron.covrig.us@ieee.org>
;;; Copyright © 2024 Evgeny Pisemsky <mail@pisemsky.site>
;;; Copyright © 2024 Markku Korkeala <markku.korkeala@iki.fi>
+;;; Copyright © 2025 Arjan Adriaanse <arjan@adriaan.se>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -11202,6 +11203,27 @@ (define-public python-executor
particularly the AST node being executed.")
(license license:expat))) ; MIT license
+(define-public python-expandvars
+ (package
+ (name "python-expandvars")
+ (version "0.12.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "expandvars" version))
+ (sha256
+ (base32 "0i6q4i8dzsax85w1l2hc7saymyh3fw43vkifh5flpkr8ayjxy6kx"))))
+ (build-system pyproject-build-system)
+ (native-inputs
+ (list python-hatchling
+ python-pytest))
+ (home-page "https://github.com/sayanarijit/expandvars")
+ (synopsis "Expand system variables Unix style")
+ (description "@code{expandvars} is inspired by GNU bash's variable
+expansion features. It can be used as an alternative to Python's
+@code{os.path.expandvars} function.")
+ (license license:expat)))
+
(define-public python-roifile
(package
(name "python-roifile")