[bug#74708] gnu: add wideriver.
Commit Message
Change-Id: Iab2a6bd8bd02098105848d240af0271df44b58bf
---
gnu/packages/wm.scm | 32 ++++++++++++++++++++++++++++++++
1 file changed, 32 insertions(+)
base-commit: d75d1fe6ac7ded7e61322d18b07d347beb609aa0
@@ -3999,3 +3999,35 @@ (define-public scenefx
"A drop-in replacement for the wlroots scene API that allows wayland
compositors to render surfaces with eye-candy effects.")
(license license:expat)))
+
+(define-public wideriver
+ (package
+ (name "wideriver")
+ (version "1.2.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/alex-courtis/wideriver")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "16i0mzgxn32nrh5ajn0kb4xdwmsjg03amhasxhwyvspar5y4flhg"))))
+ (build-system gnu-build-system)
+
+ (arguments
+ (list
+ #:tests? #f
+ #:make-flags #~(list (string-append "PREFIX="
+ #$output)
+ (string-append "CC="
+ #$(cc-for-target)))
+ #:phases #~(modify-phases %standard-phases
+ (delete 'configure))))
+ (native-inputs (list pkg-config))
+ (inputs (list wayland wayland-protocols wlroots))
+ (home-page "https://github.com/alex-courtis/wideriver")
+ (synopsis "A set of riverWM layouts")
+ (description
+ "Tiling window manager for the river wayland compositor, inspired by dwm and xmonad.")
+ (license license:gpl3)))