[bug#77682,2/2] gnu: orca: Fix xkbcomp path.

Message ID df2c08579ee8331a20d3ba407152cdd0e17c8031.1744233847.git.noelopez@free.fr
State New
Headers
Series Restore the Orca screen reader. |

Commit Message

NoƩ Lopez April 9, 2025, 9:49 p.m. UTC
  The calling code was moved to a different file where substitute* was not
changing it.

* gnu/packages/gnome.scm (orca): Change file for xkbcomp substitution.

Change-Id: I92751b0fd639042007e956b234b9f248845a3970
---
 gnu/packages/gnome.scm | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
  

Patch

diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 59c923d433..6251b1aa2c 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -11672,7 +11672,7 @@  (define-public orca
                              (assoc-ref inputs "xkbcomp") "/bin/xkbcomp"))
                    (pgrep (string-append
                            (assoc-ref inputs "procps") "/bin/pgrep")))
-               (substitute* "src/orca/orca.py"
+               (substitute* "src/orca/orca_modifier_manager.py"
                  (("'xkbcomp'") (format #f "'~a'" xkbcomp)))
                (substitute* "src/orca/debug.py"
                  (("'pgrep %s'")