diff mbox series

[bug#65556] Added SiriKali

Message ID deeb29560251c3fbefc8a895dc113e0206dc2e52.1693085004.git.aaron.covrig.us@ieee.org
State New
Headers show
Series [bug#65556] Added SiriKali | expand

Commit Message

Aaron Covrig Aug. 26, 2023, 9:23 p.m. UTC
Project main page: https://mhogomchungu.github.io/sirikali/
Project GitHub: https://github.com/mhogomchungu/sirikali

Comment: SiriKali provides a user friendly GUI for managing
encrypted folders and supports 'cloud friendly' encryption
such as CryFS, where the encrypted contents are split across
multiple encrypted blocks. These blocks only update as their
respective contents are changed, allowing for easier syncing
across network links by simplifying resumption of interrupted
transfers and providing smaller units for differential
transfer deltas.
---
 gnu/packages/sirikali.scm | 59 +++++++++++++++++++++++++++++++++++++++
 1 file changed, 59 insertions(+)
 create mode 100644 gnu/packages/sirikali.scm


base-commit: cfe55b220a2e21ec6314acd2fbaa5a780ea77afc

Comments

Ludovic Courtès Oct. 19, 2023, 8:07 p.m. UTC | #1
Hi Aaron,

Sorry for the long delay!

Aaron Covrig <aaron.covrig.us@ieee.org> skribis:

> Project main page: https://mhogomchungu.github.io/sirikali/
> Project GitHub: https://github.com/mhogomchungu/sirikali
>
> Comment: SiriKali provides a user friendly GUI for managing
> encrypted folders and supports 'cloud friendly' encryption
> such as CryFS, where the encrypted contents are split across
> multiple encrypted blocks. These blocks only update as their
> respective contents are changed, allowing for easier syncing
> across network links by simplifying resumption of interrupted
> transfers and providing smaller units for differential
> transfer deltas.

The comment above should rather complement the ‘description’ field of
the package.

For the commit log, we use a peculiar convention that consists in
describing the changes in terms of files, variables, etc.:

  https://guix.gnu.org/manual/devel/en/html_node/Submitting-Patches.html

(One of us can fix it up for you though, if needed.)

> +++ b/gnu/packages/sirikali.scm

Rather than create a new file, I’d suggest putting it in
file-systems.scm.

> +    (build-system cmake-build-system)
> +    (arguments
> +     '(#:tests? #f ;No tests
> +       #:configure-flags '("-DQT5=true" "-DCMAKE_BUILD_TYPE=RELEASE")))

You can remove “-DCMAKE_BUILD_TYPE=RELEASE” (the default is
“RelWithDebInfo”).

Could you send an updated patch?

Thanks in advance,
Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/sirikali.scm b/gnu/packages/sirikali.scm
new file mode 100644
index 0000000000..a81775f0ce
--- /dev/null
+++ b/gnu/packages/sirikali.scm
@@ -0,0 +1,59 @@ 
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2023 Aaron Covrig <aaron.covrig.us@ieee.org>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages sirikali)
+  #:use-module (guix git-download)
+  #:use-module (guix packages)
+  #:use-module (guix build-system cmake)
+  #:use-module (gnu packages)
+  #:use-module (gnu packages freedesktop)
+  #:use-module (gnu packages gnome)
+  #:use-module (gnu packages gnupg)
+  #:use-module (gnu packages password-utils)
+  #:use-module (gnu packages pkg-config)
+  #:use-module (gnu packages qt)
+  #:use-module (gnu packages check)
+  #:use-module ((guix licenses)
+                #:prefix license:))
+
+(define-public sirikali
+  (package
+    (name "sirikali")
+    (version "1.5.1")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/mhogomchungu/sirikali")
+                    (commit version)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1l52s8rxkfcxcx3s2fnsh08wy6hhjjvp7gcggdi84aqc4dq3rdnm"))))
+    (build-system cmake-build-system)
+    (arguments
+     '(#:tests? #f ;No tests
+       #:configure-flags '("-DQT5=true" "-DCMAKE_BUILD_TYPE=RELEASE")))
+    (inputs (list xdg-utils libpwquality libgcrypt libsecret qtbase-5))
+    (native-inputs (list pkg-config))
+    (home-page "https://mhogomchungu.github.io/sirikali/")
+    (synopsis
+     "GUI front end to sshfs, ecryptfs, cryfs, gocryptfs, securefs, fscrypt and encfs")
+    (description "@dfn{SiriKali} is a Qt/C++ GUI application that manages
+ecryptfs, cryfs, encfs, gocryptfs, fscrypt and securefs
+based encrypted folders")
+    (license (list license:gpl3 license:gpl2))))