diff mbox series

[bug#72474,21/30] gnu: Add erlang-yconf.

Message ID de808745cebb36bda0a5509c7b2db17d85027cd3.1722851684.git.igor@goryachev.org
State New
Headers show
Series Add ejabberd package. | expand

Commit Message

Igor Goryachev Aug. 5, 2024, 10:44 a.m. UTC
* gnu/packages/erlang-xyz.scm (erlang-yconf): New variable.

Change-Id: I01618befa77933613a60defca2a8c25067754e49
---
 gnu/packages/erlang-xyz.scm | 17 +++++++++++++++++
 1 file changed, 17 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/erlang-xyz.scm b/gnu/packages/erlang-xyz.scm
index 7d03590639..565de27608 100644
--- a/gnu/packages/erlang-xyz.scm
+++ b/gnu/packages/erlang-xyz.scm
@@ -384,6 +384,23 @@  (define-public erlang-fast-yaml
     (home-page "https://hex.pm/packages/fast_yaml")
     (license license:asl2.0)))
 
+(define-public erlang-yconf
+  (package
+    (name "erlang-yconf")
+    (version "1.0.16")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (hexpm-uri "yconf" version))
+       (sha256
+        (base32 "12bcb0w0nc30bws4lx2ghnz7n755r6nf9a75nb3i31zkfcr82iz9"))))
+    (build-system rebar-build-system)
+    (inputs (list erlang-fast-yaml))
+    (synopsis "YAML configuration processor")
+    (description "This package provides YAML configuration processor.")
+    (home-page "https://hex.pm/packages/yconf")
+    (license license:asl2.0)))
+
 (define-public erlang-unicode-util-compat
   (package
     (name "erlang-unicode-util-compat")