diff mbox series

[bug#63599] gnu: Remove bitcoin-abc.

Message ID dde71f646fb2246d7dbdcbb3c8554fa7448a249d.1684569575.git.glv@posteo.net
State New
Headers show
Series [bug#63599] gnu: Remove bitcoin-abc. | expand

Commit Message

Guillaume Le Vaillant May 20, 2023, 8:02 a.m. UTC
This package (version 0.21.12 from July 2020, which currently doesn't build)
is for an outdated version of the Bitcoin Cash protocol. Since November 2020,
the bitcoin-abc program has become an implementation of the eCash protocol,
which is different from Bitcoin Cash (different consensus model).

* gnu/packages/finance.scm (bitcoin-abc): Remove variable.
---
 gnu/packages/finance.scm | 66 ----------------------------------------
 1 file changed, 66 deletions(-)


base-commit: 24b6f94cf9b4ab97ef2eb70d05b2104a06776e62

Comments

Simon Tournier May 26, 2023, 11:25 a.m. UTC | #1
Hi,

On sam., 20 mai 2023 at 08:02, Guillaume Le Vaillant <glv@posteo.net> wrote:
> This package (version 0.21.12 from July 2020, which currently doesn't build)
> is for an outdated version of the Bitcoin Cash protocol. Since November 2020,
> the bitcoin-abc program has become an implementation of the eCash protocol,
> which is different from Bitcoin Cash (different consensus model).
>
> * gnu/packages/finance.scm (bitcoin-abc): Remove variable.
> ---
>  gnu/packages/finance.scm | 66 ----------------------------------------
>  1 file changed, 66 deletions(-)

Pushed as bb6ddc269f776e0c3dc739fb9f49a4c048db3b44.

Cheers,
simon

PS: My first push. :-)
diff mbox series

Patch

diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index 559b22257b..4e2a1c5415 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -1683,72 +1683,6 @@  (define-public trezord
 Trezor wallet.")
     (license license:lgpl3+)))
 
-(define-public bitcoin-abc
-  (package
-    (name "bitcoin-abc")
-    (version "0.21.12")
-    (source (origin
-              (method url-fetch)
-              (uri (string-append "https://download.bitcoinabc.org/"
-                                  version "/src/bitcoin-abc-"
-                                  version ".tar.gz"))
-              (sha256
-               (base32
-                "1amzwy3gpl8ai90dsy7g0z51qq8vxfzbf642wn4bfynb8jmw3kx5"))))
-    (build-system cmake-build-system)
-    (native-inputs
-     (list pkg-config
-           python ; for the tests
-           util-linux ; provides the hexdump command for tests
-           qttools-5))
-    (inputs
-     (list bdb-5.3
-           boost
-           jemalloc
-           libevent
-           miniupnpc
-           openssl
-           protobuf
-           qrencode
-           qtbase-5
-           zeromq
-           zlib))
-    (arguments
-     `(#:phases
-       (modify-phases %standard-phases
-         (add-before 'configure 'make-qt-deterministic
-           (lambda _
-             ;; Make Qt deterministic.
-             (setenv "QT_RCC_SOURCE_DATE_OVERRIDE" "1")
-             #t))
-         (add-before 'check 'set-home
-           (lambda _
-             (setenv "HOME" (getenv "TMPDIR")) ; tests write to $HOME
-             #t))
-         (add-after 'check 'check-functional
-           (lambda _
-             (invoke
-              "python3" "./test/functional/test_runner.py"
-              (string-append "--jobs=" (number->string (parallel-job-count)))
-              ;; TODO: find why the abc-miner-fund test fails.
-              "--exclude=abc-miner-fund")
-             #t)))))
-    (home-page "https://www.bitcoinabc.org/")
-    (synopsis "Bitcoin ABC peer-to-peer full node for the Bitcoin Cash protocol")
-    (description
-     "Bitcoin Cash brings sound money to the world, fulfilling the original
-promise of Bitcoin as Peer-to-Peer Electronic Cash.  Merchants and users are
-empowered with low fees and reliable confirmations is a digital currency that
-enables instant payments to anyone anywhere in the world.  It uses
-peer-to-peer technology to operate without central authority: managing
-transactions and issuing money are carried out collectively by the network.
-As a fork it implemented changes lowering the time between blocks and now
-offers confimations after less than 5 seconds and have significantly lower
-fees that BTC.  Bitcoin ABC is the reference implementation of the Bitcoin
-Cash protocol.  This package provides the Bitcoin Cash command line client and
-a client based on Qt.  This is a fork of Bitcoin Core.")
-    (license license:expat)))
-
 (define-public libofx
   (package
     (name "libofx")