diff mbox series

[bug#63299] gnu: Add qimgv

Message ID ddd7b108-73f5-602d-eef3-9f5d70efc214@pantherx.org
State New
Headers show
Series [bug#63299] gnu: Add qimgv | expand

Commit Message

Franz Geffke May 5, 2023, 10:41 a.m. UTC

diff mbox series

Patch

diff --git a/gnu/packages/image-viewers.scm b/gnu/packages/image-viewers.scm
index a5b3e3e825..3986614a4b 100644
--- a/gnu/packages/image-viewers.scm
+++ b/gnu/packages/image-viewers.scm
@@ -1158,3 +1158,32 @@  (define-public hydrus-network
  any user may run.  Everything is free and privacy is the first concern.")
      (home-page "https://hydrusnetwork.github.io/hydrus/")
      (license license:wtfpl2)))
+
+(define-public qimgv
+  (package
+    (name "qimgv")
+    (version "1.0.3-alpha")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "https://github.com/easymodo/"
+                           name "/archive/v" version ".tar.gz"))
+       (sha256
+        (base32
+         "1jcr2f6b2hjss4qiih9nvla1xryf9c4dnp3f1cfqkccxszikxh4l"))))
+    (build-system cmake-build-system)
+    (arguments `(#:tests? #f))
+    (native-inputs
+     `(("exiv2" ,exiv2)
+       ("gcc" ,gcc)
+       ("mpv" ,mpv)
+       ("opencv" ,opencv)
+       ("pkg-config" ,pkg-config)
+       ("qtbase" ,qtbase)
+       ("qtsvg" ,qtsvg)
+       ("qttools" ,qttools)))
+    (home-page "https://github.com/easymodo/qimgv")
+    (synopsis "Qt5 image viewer with optional video support")
+    (description "Qt5 image viewer. Fast, configurable, easy to use.
+Optional video support.")
+    (license license:gpl3+)))