diff mbox series

[bug#39786] Acknowledgement ([PATCH] Add dragonfly-reverb.)

Message ID ddc5e65dd3808789a2335520f066c53353709965.camel@zrythm.org
State Accepted
Headers show
Series [bug#39786] Acknowledgement ([PATCH] Add dragonfly-reverb.) | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

Alexandros Theodotou Feb. 26, 2020, 9:49 p.m. UTC
I have removed VST because it is not really necessary. This now only
outputs LV2 and standalone versions.

To test that the plugin works, you can run the following if you already
have JACK running:
LV2_PATH=/gnu/store/xbhdmal9ybvw8yrynmimmj0z9cg2v6aj-dragonfly-reverb-
2.0.0/lib/lv2 jalv.gtk3 urn:dragonfly:room
LV2_PATH=/gnu/store/xbhdmal9ybvw8yrynmimmj0z9cg2v6aj-dragonfly-reverb-2.0.0/lib/lv2 jalv.gtk3 https://github.com/michaelwillis/dragonfly-reverb
If you don't have JACK running (most likely case), you can run a dummy
server temporarily with `jackd -ddummy`.

Thanks,
Alex
diff mbox series

Patch

From 619221725965d5046161ca4c49cc214d25744245 Mon Sep 17 00:00:00 2001
From: Alexandros Theodotou <alex@zrythm.org>
Date: Tue, 25 Feb 2020 15:17:10 +0000
Subject: [PATCH] gnu: Add dragonfly-reverb

* gnu/packages/music.scm (dragonfly-reverb): New variable.
---
 gnu/packages/music.scm | 55 ++++++++++++++++++++++++++++++++++++++++++
 1 file changed, 55 insertions(+)

diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 16e69840df..21825ef333 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -5189,3 +5189,58 @@  featureful and easy to use.  It offers unlimited automation options, LV2
 plugin support, JACK support and chord assistance.")
    (home-page "https://www.zrythm.org")
    (license license:agpl3+)))
+
+(define-public dragonfly-reverb
+  (package
+    (name "dragonfly-reverb")
+    (version "2.0.0")
+    (source
+      (origin
+        (method git-fetch)
+        (uri
+          (git-reference
+            (url "https://github.com/michaelwillis/dragonfly-reverb.git")
+            (commit version)
+            ;; bundles a specific commit of the DISTRHO plugin framework
+            (recursive? #t)))
+        (file-name (git-file-name name version))
+        (sha256
+          (base32 "1qrbv4kk5v6ynx424h1i54qj0w8v6vpw81b759jawxvzzprpgq72"))))
+    (build-system gnu-build-system)
+    (arguments
+     `(#:tests? #f ; no check target
+       #:make-flags (list "CC=gcc")
+       #:phases
+       (modify-phases %standard-phases
+         (delete 'configure) ; no configure target
+         (replace 'install ; no install target
+           (lambda* (#:key inputs outputs #:allow-other-keys)
+             (let* ((out   (assoc-ref outputs "out"))
+                    (bin   (string-append out "/bin"))
+                    (lv2   (string-append out "/lib/lv2")))
+               (mkdir-p bin)
+               (mkdir-p lv2)
+               ;; Install LV2
+               (for-each
+                 (lambda (file)
+                   (copy-recursively file (string-append lv2 "/"
+                                                         (basename file))))
+                 (find-files "bin" "\\.lv2$" #:directories? #t))
+               ;; Install standalone
+               (install-file "bin/DragonflyRoomReverb" bin)
+               (install-file "bin/DragonflyHallReverb" bin)
+               #t))))))
+    (inputs
+     `(("jack" ,jack-1)
+       ("libx11" ,libx11)
+       ("mesa" ,mesa)))
+    (native-inputs
+     `(("lv2" ,lv2)
+       ("pkg-config" ,pkg-config)))
+    (synopsis "Concert hall reverb and room reverb effects")
+    (description
+     "Dragonfly Reverb is a bundle of two free audio effects: a concert
+hall reverb and a room reverb. Both are available as LV2 plugins as well
+as JACK standalone applications.")
+    (home-page "https://michaelwillis.github.io/dragonfly-reverb/")
+    (license license:gpl3+)))
-- 
2.25.1