diff mbox series

[bug#71968,v7,3/3] gnu: fastfetch: Add more configure flags.

Message ID dda640c73d7fa0d87ad726f794011566e4ba0890.1732090301.git.dariqq@posteo.net
State New
Headers show
Series fastfetch: Unbundle yyjson, update and package improvements | expand

Commit Message

Dariqq Nov. 20, 2024, 8:32 a.m. UTC
Use dynamic linking for dependencies instead of dlopening them at runtime which requries a wrapper with LD_LIBRARY_PATH.

Additionally provide custom paths to pci-ids and amdgpu-ids.

* gnu/packages/admin.scm (fastfetch)
[#:configure-flags]: Enable dynamic linking and disable directx-headers. Set
custom paths to hwdata and libdrm.
[inputs]: Add hwdata and libdrm for the custom paths.

Change-Id: I9f86b49f0a116bcee91ca15b6e77cfbb3867e290
---
 gnu/packages/admin.scm | 12 +++++++++++-
 1 file changed, 11 insertions(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 78c6e904b8..ca1deaf520 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -4325,10 +4325,20 @@  (define-public fastfetch
      (list
       #:configure-flags #~(list "-DENABLE_SYSTEM_YYJSON=ON"
                                 "-DBUILD_TESTS=ON"
-                                "-DINSTALL_LICENSE=OFF")))
+                                "-DINSTALL_LICENSE=OFF"
+                                "-DBINARY_LINK_TYPE=dynamic"
+                                "-DENABLE_DIRECTX_HEADERS=OFF"
+                                (string-append "-DCUSTOM_PCI_IDS_PATH="
+                                               #$(this-package-input "hwdata")
+                                               "/share/hwdata/pci.ids")
+                                (string-append "-DCUSTOM_AMDGPU_IDS_PATH="
+                                               #$(this-package-input "libdrm")
+                                               "share/libdrm/amdgpu.ids"))))
     (inputs (list dbus
                   glib
+                  hwdata
                   imagemagick
+                  libdrm
                   libxcb
                   mesa
                   wayland