diff mbox series

[bug#61651] gnu: gnunet: Update to 0.19.3.

Message ID dd9a732a-296b-2af8-42dc-a1abfdf88ab3@disroot.org
State New
Headers show
Series [bug#61651] gnu: gnunet: Update to 0.19.3. | expand

Commit Message

Adam Faiz Feb. 20, 2023, 1:47 p.m. UTC
From 7bfd653e503e7e8be16179ed1ba2ac15b303c8b7 Mon Sep 17 00:00:00 2001
Message-Id: 
<7bfd653e503e7e8be16179ed1ba2ac15b303c8b7.1676897203.git.adam.faiz@disroot.org>
From: AwesomeAdam54321 <adam.faiz@disroot.org>
Date: Mon, 20 Feb 2023 19:53:03 +0800
Subject: [PATCH] gnu: gnunet: Update to 0.19.3.

* gnu/packages/gnunet.scm (gnunet): Update to 0.19.3.
---
  gnu/packages/gnunet.scm | 17 +++++++++++++----
  1 file changed, 13 insertions(+), 4 deletions(-)

      '(#:parallel-tests? #f ; Parallel tests aren't supported.

base-commit: 08edbd2535ae622d319a51e6f877d23d75dc24f3

Comments

Guillaume Le Vaillant Feb. 22, 2023, 4:08 p.m. UTC | #1
Patches pushed as 6d53351a6d13039eb076e584d13225e0158c5a08 and
following.
Thanks.

Note: The patch for updating gnunet was mangled by your email client (it
cut a long line in native-inputs in two). To prevent this from
happening, you can use the "git send-email" command, or send patches as
attachments, or set your email client to no-line-cutting-mode if that's
possible.
diff mbox series

Patch

diff --git a/gnu/packages/gnunet.scm b/gnu/packages/gnunet.scm
index c98ceefad7..58349a798d 100644
--- a/gnu/packages/gnunet.scm
+++ b/gnu/packages/gnunet.scm
@@ -37,6 +37,7 @@  (define-module (gnu packages gnunet)
    #:use-module (gnu packages compression)
    #:use-module (gnu packages crypto)
    #:use-module (gnu packages curl)
+  #:use-module (gnu packages freedesktop)
    #:use-module (gnu packages gettext)
    #:use-module (gnu packages glib)
    #:use-module (gnu packages gnome)
@@ -60,6 +61,7 @@  (define-module (gnu packages gnunet)
    #:use-module (gnu packages perl)
    #:use-module (gnu packages pulseaudio)
    #:use-module (gnu packages python)
+  #:use-module (gnu packages sphinx)
    #:use-module (gnu packages sqlite)
    #:use-module (gnu packages text-editors)
    #:use-module (gnu packages tls)
@@ -258,7 +260,7 @@  (define-public gnurl
  (define-public gnunet
    (package
     (name "gnunet")
-   (version "0.16.3")
+   (version "0.19.3")
     (source
      (origin
        (method url-fetch)
@@ -266,12 +268,19 @@  (define-public gnunet
                            ".tar.gz"))
        (sha256
         (base32
-        "12n33r9nnkl5xwx8pwf571l2zvnvfllc8vm6mamrlyjk2cphaf9j"))))
+        "09bspbjl6cll8wcrl1vnb56jwp30pcrg1yyj6xy3i0fl2bzdbdw2"))
+      (modules '((guix build utils)))
+      (snippet
+       #~(begin
+           ;; This is fixed in the upstream repository but the fix
+           ;; has not been released.
+           (substitute* "src/gns/test_proxy.sh"
+             (("test_gnunet_proxy.conf") "test_gns_proxy.conf"))))))
     (build-system gnu-build-system)
     (inputs
      (list bluez
            glpk
-          gnurl
+          curl
            gnutls/dane
            gstreamer
            jansson
@@ -291,7 +300,7 @@  (define-public gnunet
            zbar
            zlib))
     (native-inputs
-    (list curl openssl pkg-config python xxd
+    (list curl openssl pkg-config python xxd python-sphinx 
python-sphinx-rtd-theme
            (@ (gnu packages base) which)))
     (arguments