[bug#76480,46/51] gnu: Add python-s3path.

Message ID dd6d1c2e5011b1758ddad85c289ab8959ebb99f9.1740173176.git.sharlatanus@gmail.com
State New
Headers
Series Astro update 2025/02 |

Commit Message

Sharlatan Hellseher Feb. 21, 2025, 9:49 p.m. UTC
  * gnu/packages/python-web.scm (python-s3path): New variable.

Change-Id: I04c3fe63b9bf4b37d76a78c1df35617495955414
---
 gnu/packages/python-web.scm | 28 ++++++++++++++++++++++++++++
 1 file changed, 28 insertions(+)
  

Patch

diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 3430997abcb..840855805ae 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -1805,6 +1805,34 @@  (define-public python-requests-cache
 files.")
     (license license:bsd-2)))
 
+(define-public python-s3path
+  (package
+    (name "python-s3path")
+    (version "0.6.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "s3path" version))
+       (sha256
+        (base32 "0gbvyr60mkpm7jbjiya0pmx26q6cfp27p5czw08jwn3k5cp77krk"))))
+    (build-system pyproject-build-system)
+    (arguments
+     (list
+      ;; XXX: All tests fail with error: fixture 's3_mock' not found.
+      #:tests? #f))
+    (native-inputs
+     (list python-setuptools
+           python-wheel))
+    (propagated-inputs
+     (list python-boto3
+           python-smart-open))
+    (home-page "https://github.com/liormizr/s3path")
+    (synopsis "Pathlib extension for AWS S3 Service")
+    (description
+     "S3Path provide a Python convenient File-System/Path like interface for
+AWS S3 Service using boto3 S3 resource as a driver.")
+    (license license:asl2.0)))
+
 (define-public python-sarif-om
   (package
     (name "python-sarif-om")