diff mbox series

[bug#71607] gnu: python-pyld: Update to 2.0.4

Message ID dd3f5842f4ddb878f67683a53917f6603230f315.1718605741.git.ben@sturm.com.au
State New
Headers show
Series [bug#71607] gnu: python-pyld: Update to 2.0.4 | expand

Commit Message

Ben Sturmfels June 17, 2024, 6:29 a.m. UTC
* gnu/packages/python-xyz.scm (python-pyld): Update to 2.0.4

Change-Id: Iebd823a94c8f39944162056d451176d112e229e3
---
 gnu/packages/python-xyz.scm | 19 ++++++++++---------
 1 file changed, 10 insertions(+), 9 deletions(-)


base-commit: bd5c61781c13611ed16686513980907c6ee34ae6

Comments

jgart June 17, 2024, 10:29 p.m. UTC | #1
Hi,

Thanks for contributing to GNU Guix! 

Applied with added periods at the end of commit messages, observing Guix commit style.

all best,

jgart
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index c98453039b..ad4630d9c1 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -5411,18 +5411,19 @@  (define-public python-exif-read
 (define-public python-pyld
   (package
     (name "python-pyld")
-    (version "1.0.5")
-    (source (origin
-              (method url-fetch)
-              (uri (pypi-uri "PyLD" version))
-              (sha256
-               (base32
-                "1ywbdbsrkg533qh8xn9ifjh2mvam6v5msrjyqq73jfpvcp89qvff"))))
+    (version "2.0.4")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "PyLD" version))
+       (sha256
+        (base32 "1k7ars8n6kramkvadxgy0qfsi5g1hipyha4wqw8l75mw1l7ka7ii"))))
     (build-system python-build-system)
+    (native-inputs (list python-lxml))
+    (propagated-inputs (list python-cachetools python-frozendict))
     (home-page "https://github.com/digitalbazaar/pyld")
     (synopsis "Python implementation of the JSON-LD specification")
-    (description
-     "PyLD is an implementation of the JSON-LD specification.")
+    (description "PyLD is an implementation of the JSON-LD specification.")
     (license license:bsd-3)))
 
 (define-public python-cli-helpers