diff mbox series

[bug#68712,2/4] gnu: python-clorm: Reindent with emacs.

Message ID dc5c3cc02da05175c0491e522b9bfc18eade9095.1706178350.git.liliana.prikler@gmail.com
State New
Headers show
Series More clingo stuff. | expand

Commit Message

Liliana Marie Prikler Jan. 25, 2024, 9:44 a.m. UTC
* gnu/packages/potassco.scm (python-clorm): Reindent with emacs.
---
 gnu/packages/potassco.scm | 58 +++++++++++++++++++--------------------
 1 file changed, 29 insertions(+), 29 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/potassco.scm b/gnu/packages/potassco.scm
index afc4c4d513..0ec6253099 100644
--- a/gnu/packages/potassco.scm
+++ b/gnu/packages/potassco.scm
@@ -406,38 +406,38 @@  (define-public python-clingo-dl
 
 (define-public python-clorm
   (package
-   (name "python-clorm")
-   (version "1.4.1")
-   (source (origin
-            (method git-fetch)
-            (uri (git-reference
-                  (url "https://github.com/potassco/clorm")
-                  (commit (string-append "v" version))))
-            (file-name (git-file-name name version))
-            (sha256
-             (base32
-              "0jx99y71mrgdicn1da5dwz5nzgvvpabrikff783sg4shbv2cf0b5"))))
-   (build-system pyproject-build-system)
-   (arguments
-    (list #:phases
-          #~(modify-phases %standard-phases
-              (add-before 'check 'fix-breaking-tests
-                (lambda _
-                  ;; noclingo tests rely on this being set
-                  (setenv "CLORM_NOCLINGO" "1")
-                  (delete-file "tests/test_mypy_query.py")
-                  (substitute* "tests/test_clingo.py"
-                    (("self\\.assertTrue\\(os_called\\)" all)
-                     (string-append "# " all))))))))
-   (propagated-inputs (list python-clingo))
-   (native-inputs (list python-typing-extensions))
-   (home-page "https://potassco.org")
-   (synopsis "Object relational mapping to clingo")
-   (description "@acronym{Clorm, Clingo ORM} provides an @acronym{ORM,
+    (name "python-clorm")
+    (version "1.4.1")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/potassco/clorm")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0jx99y71mrgdicn1da5dwz5nzgvvpabrikff783sg4shbv2cf0b5"))))
+    (build-system pyproject-build-system)
+    (arguments
+     (list #:phases
+           #~(modify-phases %standard-phases
+               (add-before 'check 'fix-breaking-tests
+                 (lambda _
+                   ;; noclingo tests rely on this being set
+                   (setenv "CLORM_NOCLINGO" "1")
+                   (delete-file "tests/test_mypy_query.py")
+                   (substitute* "tests/test_clingo.py"
+                     (("self\\.assertTrue\\(os_called\\)" all)
+                      (string-append "# " all))))))))
+    (propagated-inputs (list python-clingo))
+    (native-inputs (list python-typing-extensions))
+    (home-page "https://potassco.org")
+    (synopsis "Object relational mapping to clingo")
+    (description "@acronym{Clorm, Clingo ORM} provides an @acronym{ORM,
 Object Relational Mapping} interface to the @acronym{ASP, answer set
 programming} solver clingo.  Its goal is to make integration of clingo
 into Python programs easier.")
-   (license license:expat)))
+    (license license:expat)))
 
 (define-public python-telingo
   (package