diff mbox series

[bug#59998] gnu: emacs-xyz: Update emacs-dashboard

Message ID dc47f768e45a9f1b1088057517a40f81aac81b87.1670841070.git.florhizome@posteo.net
State New
Headers show
Series [bug#59998] gnu: emacs-xyz: Update emacs-dashboard | expand

Commit Message

florhizome Dec. 12, 2022, 10:39 a.m. UTC
From: florhizome <florhizome@posteo.net>


* gnu/packages/emacs-xyz.scm (emacs-dashboard): Update to newest commit
---
 gnu/packages/emacs-xyz.scm | 11 +++++++----
 1 file changed, 7 insertions(+), 4 deletions(-)

Comments

Nicolas Goaziou Dec. 12, 2022, 12:26 p.m. UTC | #1
Hello,

florhizome@posteo.net writes:

> * gnu/packages/emacs-xyz.scm (emacs-dashboard): Update to newest
> commit

Thank you.

Is there a reason to use a commit instead of latest release? We usually
prefer the former.

>  (define-public emacs-dashboard
> +  (let ((version "1.8.0")

Version is still 1.7.0. Version keyword mentions 1.8.0-SNAPSHOT, which,
as I read it, means upstream has not released 1.8.0 yet.

Regards,
Nicolas Goaziou Dec. 12, 2022, 12:28 p.m. UTC | #2
Nicolas Goaziou <mail@nicolasgoaziou.fr> writes:

> Is there a reason to use a commit instead of latest release? We usually
> prefer the former.

I meant "the latter". Duh.
florhizome Dec. 20, 2022, 6:12 p.m. UTC | #3
Hi!

On 2022-12-12, 13:26 +0100, Nicolas Goaziou <mail@nicolasgoaziou.fr> wrote:

> Hello,
>
> florhizome@posteo.net writes:
>
>> * gnu/packages/emacs-xyz.scm (emacs-dashboard): Update to newest
>> commit
>
> Thank you.
>
> Is there a reason to use a commit instead of latest release? We usually
> prefer the former.
>

Because the latest release is in february 2020, and my personal problems
have started much later, I think a few months ago.
Nicolas Goaziou Dec. 22, 2022, 10:34 p.m. UTC | #4
Hello,

florhizome@posteo.net writes:

> From: florhizome <florhizome@posteo.net>
>
>
> * gnu/packages/emacs-xyz.scm (emacs-dashboard): Update to newest
> commit

Switched base version to 1.7.0 and applied. Thank you.

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 18d1989124..469022fbe0 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -22974,18 +22974,21 @@  (define-public emacs-highlight-escape-sequences
       (license license:gpl3+))))
 
 (define-public emacs-dashboard
+  (let ((version "1.8.0")
+        (commit "6cdefdfd96c740d0e744b0c346360e28afad3acf")
+        (revision "0"))
   (package
     (name "emacs-dashboard")
-    (version "1.7.0")
+    (version (git-version version revision commit))
     (source
      (origin
        (method git-fetch)
        (uri (git-reference
              (url "https://github.com/rakanalh/emacs-dashboard")
-             (commit version)))
+             (commit commit)))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "1qv4cqjy2s2d2bysbq10vq1axpbd8qc3jn1s1r81lxqkcja8zasa"))))
+        (base32 "1iwp3rzi76hfwysi5a39zj9lv9140mzvqbccl69g3d5jnzd90h28"))))
     (build-system emacs-build-system)
     (propagated-inputs
      (list emacs-page-break-lines))
@@ -23005,7 +23008,7 @@  (define-public emacs-dashboard
     (synopsis "Startup screen extracted from Spacemacs")
     (description "This package provides an extensible Emacs dashboard, with
 sections for bookmarks, projectil projects, org-agenda and more.")
-    (license license:gpl3+)))
+    (license license:gpl3+))))
 
 (define-public emacs-slime-company
   (package