[bug#77391,v2,4/4] gnu: emacs-ellama: Enable tests; install info manual.
Commit Message
* gnu/packages/emacs-xyz.scm (emacs-ellama)[arguments]: Enable tests; skip
failing; install included pre-generated info manual.
Change-Id: I1b468c7b30ad35ae553d354ef63da2d4d1c056a7
---
gnu/packages/emacs-xyz.scm | 17 +++++++++++++++++
1 file changed, 17 insertions(+)
@@ -5789,6 +5789,23 @@ (define-public emacs-ellama
(sha256 (base32
"075bxdy2jzaq4nw2vpzlmxlq3mlvr0dklva5hbpzqm6pvwa2xz1k"))))
(build-system emacs-build-system)
+ (arguments
+ (list #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'disable-failing-tests
+ (lambda _
+ (substitute* (find-files "tests/" "\\.el$")
+ (("\\(ert-deftest test-ellama-context-element-extract-info-node .*" all)
+ (string-append all "(skip-unless nil)\n")))))
+ (add-after 'install 'install-info
+ (lambda _
+ (install-file "ellama.info"
+ (string-append #$output "/share/info")))))
+ #:tests? #t
+ #:test-command #~(list "emacs" "-Q" "--batch"
+ "-l" "ellama.el"
+ "-l" "tests/test-ellama.el"
+ "-f" "ert-run-tests-batch-and-exit")))
(propagated-inputs (list emacs-compat emacs-llm emacs-plz emacs-transient))
(home-page "https://github.com/s-kostyaev/ellama")
(synopsis "Tool for interacting with LLMs")