diff mbox series

[bug#62635,v4,4/4] gnu: geary: Update to 43.0.

Message ID db845a37cc47a0dc853db3da3c7930735bbc45ea.1684254549.git.liliana.prikler@gmail.com
State New
Headers show
Series [bug#62635,v4,1/4] gnu: geary: Fix build failure. | expand

Commit Message

Liliana Marie Prikler May 16, 2023, 4:24 p.m. UTC
* gnu/packages/gnome.scm (geary): Update to 43.0.
[arguments]<#:phases>: Drop ‘disable-failing-tests’ and ‘generate-vapis’.
Rename ‘disable-postinstall-script’ to ‘skip-gtk-update-icon-cache’ and adjust
accordingly.
[inputs]: Replace folks-with-libsoup2 with folks.
Replace gnome-online-accounts-3.44 with gnome-online-accounts.
Replace webkitgtk-with-libsoup2 with webkitgtk.
[native-inputs]: Replace vala-0.52 with vala.
Add gnutls.
---
Hi Juliana,

1..3/4 have my rewordings for the commit messages, but more importantly,
it turns out that geary can be refreshed to a newer version with fewer
issues to fix :)
Please confirm that this Geary also works for you.

Cheers

 gnu/packages/gnome.scm | 40 +++++++++++++---------------------------
 1 file changed, 13 insertions(+), 27 deletions(-)

Comments

Juliana Sims May 17, 2023, 12:49 p.m. UTC | #1
Hello,

> 1..3/4 have my rewordings for the commit messages, but more 
> importantly,
> it turns out that geary can be refreshed to a newer version with fewer
> issues to fix :)
> Please confirm that this Geary also works for you.
I can confirm that this Geary also works for me! For some reason it was 
failing to build when I tried to update it before, so I'm glad you 
thought to try this now :D

Thanks so much,
Juli
Liliana Marie Prikler May 21, 2023, 8:35 p.m. UTC | #2
Am Mittwoch, dem 17.05.2023 um 08:49 -0400 schrieb Juliana Sims:
> Hello,
> 
> > 1..3/4 have my rewordings for the commit messages, but more 
> > importantly,
> > it turns out that geary can be refreshed to a newer version with
> > fewer
> > issues to fix :)
> > Please confirm that this Geary also works for you.
> I can confirm that this Geary also works for me! For some reason it
> was failing to build when I tried to update it before, so I'm glad
> you thought to try this now :D
Thanks, should now be updated for everyone.

Cheers
diff mbox series

Patch

diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 81bc6c04e9..bf5420b1f0 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -12306,16 +12306,16 @@  (define-public gnome-boxes
 (define-public geary
   (package
     (name "geary")
-    (version "40.0")
+    (version "43.0")
     (source (origin
               (method git-fetch)
               (uri (git-reference
                     (url "https://gitlab.gnome.org/GNOME/geary.git")
-                    (commit (string-append "gnome-" version))))
+                    (commit version)))
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "04hvw86r8sczvjm1z3ls5y5y5h6nyfb648rjkfx05ib00mqq5v1x"))))
+                "05b8c5ljzx1ly7wq8jzpv8psxmsdlz395sr17xwj49nh495nflz5"))))
     (build-system meson-build-system)
     (arguments
      (list #:glib-or-gtk? #t
@@ -12323,27 +12323,12 @@  (define-public geary
            #~(list "-Dprofile=release")
            #:phases
            #~(modify-phases %standard-phases
-               (add-after 'unpack 'disable-failing-tests
-                 (lambda _
-                   (substitute* "test/test-client.vala"
-                     (("client.add_suite\\(new Application.CertificateManagerTest\\(\\).suite\\);")
-                      ""))
-                   (substitute* "test/test-engine.vala"
-                     (("engine.add_suite\\(new Geary.RFC822.MessageDataTest\\(\\).suite\\);")
-                      ""))))
-               (add-after 'unpack 'generate-vapis
-                 (lambda _
-                   ;; It’s not possible to generate the GMime vapi, because
-                   ;; there’s custom metadata that gmime didn’t
-                   ;; install. Thus, the vapi should be built and installed
-                   ;; with gmime.
-                   (copy-file #$(file-append gmime "/share/vala/vapi/gmime-3.0.vapi")
-                              "bindings/vapi/gmime-3.0.vapi")))
-               (add-after 'unpack 'disable-postinstall-script
+               (add-after 'unpack 'skip-gtk-update-icon-cache
+                 ;; Don't create 'icon-theme.cache'.
                  (lambda _
-                   (substitute* "build-aux/post_install.py"
-                     (("gtk-update-icon-cache")
-                      "true"))))
+                   (substitute* "meson.build"
+                     (("gtk_update_icon_cache: true")
+                      "gtk_update_icon_cache: false"))))
                (add-before 'check 'setup-home
                  (lambda _
                    ;; Tests require a writable HOME.
@@ -12354,11 +12339,11 @@  (define-public geary
                    (setenv "DISPLAY" ":1"))))))
     (inputs
      (list enchant
-           folks-with-libsoup2
+           folks
            gcr
            glib
            gmime
-           gnome-online-accounts-3.44
+           gnome-online-accounts
            gsettings-desktop-schemas
            gspell
            gsound
@@ -12373,7 +12358,7 @@  (define-public geary
            libstemmer
            libunwind
            sqlite
-           webkitgtk-with-libsoup2
+           webkitgtk
            ytnef))
     (native-inputs
      (list appstream-glib
@@ -12381,13 +12366,14 @@  (define-public geary
            desktop-file-utils
            gettext-minimal
            `(,glib "bin")
+           gnutls                       ; for certtool
            gobject-introspection
            itstool
            libarchive
            libxml2
            pkg-config
            python-minimal
-           vala-0.52
+           vala
            xorg-server-for-tests))
     (synopsis "GNOME email application built around conversations")
     (description